aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/audiomanager/audiomanager/0001-Build-plugins-as-modules-instead-of-shared-libraries.patch88
-rw-r--r--recipes-multimedia/audiomanager/audiomanager_3.2.bb15
-rw-r--r--recipes-multimedia/audiomanager/audiomanager_git.bb15
3 files changed, 100 insertions, 18 deletions
diff --git a/recipes-multimedia/audiomanager/audiomanager/0001-Build-plugins-as-modules-instead-of-shared-libraries.patch b/recipes-multimedia/audiomanager/audiomanager/0001-Build-plugins-as-modules-instead-of-shared-libraries.patch
new file mode 100644
index 0000000..4d35899
--- /dev/null
+++ b/recipes-multimedia/audiomanager/audiomanager/0001-Build-plugins-as-modules-instead-of-shared-libraries.patch
@@ -0,0 +1,88 @@
+From ab47293e8210e33a235440a14b24379fc75ba9a3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Erik=20Bot=C3=B6?= <erik.boto at pelagicore.com>
+Date: Thu, 30 May 2013 08:40:24 +0200
+Subject: [PATCH] * Build plugins as modules instead of shared libraries *
+ Don't set SOVERSION in plugins
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Erik Botö <erik.boto at pelagicore.com>
+---
+ PluginCommandInterfaceDbus/CMakeLists.txt | 6 +-----
+ PluginControlInterface/CMakeLists.txt | 6 +-----
+ PluginRoutingInterfaceAsync/CMakeLists.txt | 6 +-----
+ PluginRoutingInterfaceDbus/CMakeLists.txt | 6 +-----
+ 4 files changed, 4 insertions(+), 20 deletions(-)
+
+diff --git a/PluginCommandInterfaceDbus/CMakeLists.txt b/PluginCommandInterfaceDbus/CMakeLists.txt
+index a27e02f..faf7947 100644
+--- a/PluginCommandInterfaceDbus/CMakeLists.txt
++++ b/PluginCommandInterfaceDbus/CMakeLists.txt
+@@ -60,11 +60,7 @@ INCLUDE_DIRECTORIES(
+ # all source files go here
+ file(GLOB PLUGINDBUS_SRCS_CXX "src/*.cpp")
+
+-add_library(PluginCommandInterfaceDbus SHARED ${PLUGINDBUS_SRCS_CXX})
+-
+-SET_TARGET_PROPERTIES(PluginCommandInterfaceDbus PROPERTIES
+- SOVERSION "${LIB_INTERFACE_VERSION}"
+-)
++add_library(PluginCommandInterfaceDbus MODULE ${PLUGINDBUS_SRCS_CXX})
+
+ TARGET_LINK_LIBRARIES(PluginCommandInterfaceDbus
+ ${DLT_LIBRARIES}
+diff --git a/PluginControlInterface/CMakeLists.txt b/PluginControlInterface/CMakeLists.txt
+index 16b49be..466e079 100644
+--- a/PluginControlInterface/CMakeLists.txt
++++ b/PluginControlInterface/CMakeLists.txt
+@@ -47,11 +47,7 @@ INCLUDE_DIRECTORIES(
+ # all source files go here
+ file(GLOB PLUGIN_CONTROL_SRCS_CXX "src/*.cpp")
+
+-add_library(PluginControlInterface SHARED ${PLUGIN_CONTROL_SRCS_CXX})
+-
+-SET_TARGET_PROPERTIES(PluginControlInterface PROPERTIES
+- SOVERSION "${LIB_INTERFACE_VERSION}"
+-)
++add_library(PluginControlInterface MODULE ${PLUGIN_CONTROL_SRCS_CXX})
+
+ TARGET_LINK_LIBRARIES(PluginControlInterface
+ ${DLT_LIBRARIES})
+diff --git a/PluginRoutingInterfaceAsync/CMakeLists.txt b/PluginRoutingInterfaceAsync/CMakeLists.txt
+index b4cd576..1bf09e2 100644
+--- a/PluginRoutingInterfaceAsync/CMakeLists.txt
++++ b/PluginRoutingInterfaceAsync/CMakeLists.txt
+@@ -48,11 +48,7 @@ INCLUDE_DIRECTORIES(
+ file(GLOB PLUGINDBUS_SRCS_CXX "src/*.cpp")
+
+
+-add_library(PluginRoutingInterfaceAsync SHARED ${PLUGINDBUS_SRCS_CXX})
+-
+-SET_TARGET_PROPERTIES(PluginRoutingInterfaceAsync PROPERTIES
+- SOVERSION "${LIB_INTERFACE_VERSION}"
+-)
++add_library(PluginRoutingInterfaceAsync MODULE ${PLUGINDBUS_SRCS_CXX})
+
+ TARGET_LINK_LIBRARIES(PluginRoutingInterfaceAsync
+ ${DLT_LIBRARIES}
+diff --git a/PluginRoutingInterfaceDbus/CMakeLists.txt b/PluginRoutingInterfaceDbus/CMakeLists.txt
+index ec636c3..19b53bc 100644
+--- a/PluginRoutingInterfaceDbus/CMakeLists.txt
++++ b/PluginRoutingInterfaceDbus/CMakeLists.txt
+@@ -60,11 +60,7 @@ INCLUDE_DIRECTORIES(
+ file(GLOB PLUGINDBUS_SRCS_CXX "src/*.cpp")
+
+
+-add_library(PluginRoutingInterfaceDbus SHARED ${PLUGINDBUS_SRCS_CXX})
+-
+-SET_TARGET_PROPERTIES(PluginRoutingInterfaceDbus PROPERTIES
+- SOVERSION "${LIB_INTERFACE_VERSION}"
+-)
++add_library(PluginRoutingInterfaceDbus MODULE ${PLUGINDBUS_SRCS_CXX})
+
+ TARGET_LINK_LIBRARIES(PluginRoutingInterfaceDbus
+ ${DLT_LIBRARIES}
+--
+1.8.1.2
+
diff --git a/recipes-multimedia/audiomanager/audiomanager_3.2.bb b/recipes-multimedia/audiomanager/audiomanager_3.2.bb
index 14007fb..d3dcb56 100644
--- a/recipes-multimedia/audiomanager/audiomanager_3.2.bb
+++ b/recipes-multimedia/audiomanager/audiomanager_3.2.bb
@@ -5,12 +5,13 @@ SECTION = "multimedia"
LICENSE = "MPLv2"
LIC_FILES_CHKSUM = "file://LICENCE;md5=815ca599c9df247a0c7f619bab123dad"
-PR = "r0"
+PR = "r1"
DEPENDS = "dlt-daemon sqlite3 dbus"
SRC_URI = "git://git.projects.genivi.org/AudioManager.git;protocol=git;tag=${PV} \
- file://AudioManager.service file://setup_amgr.sh"
+ file://AudioManager.service file://setup_amgr.sh \
+ file://0001-Build-plugins-as-modules-instead-of-shared-libraries.patch"
S = "${WORKDIR}/git"
inherit autotools gettext cmake pkgconfig systemd
@@ -21,16 +22,12 @@ SYSTEMD_AUTO_ENABLE = "disable"
EXTRA_OECMAKE += "-DWITH_TESTS=OFF -DUSE_BUILD_LIBS=OFF"
OECMAKE_CXX_FLAGS +="-ldl"
-FILES_${PN} += "${libdir}/audioManager/command/*.so.* \
- ${libdir}/audioManager/control/*.so.* \
- ${libdir}/audioManager/routing/*.so.* \
+FILES_${PN} += "${libdir}/audioManager/command/*.so* \
+ ${libdir}/audioManager/control/*.so* \
+ ${libdir}/audioManager/routing/*.so* \
${systemd_unitdir}/AudioManager.service \
${systemd_unitdir}/scripts/setup_amgr.sh \
"
-FILES_${PN}-dev += "${libdir}/audioManager/command/*.so \
- ${libdir}/audioManager/control/*.so \
- ${libdir}/audioManager/routing/*.so \
-"
FILES_${PN}-dbg += "${libdir}/audioManager/command/.debug/* \
${libdir}/audioManager/control/.debug/* \
diff --git a/recipes-multimedia/audiomanager/audiomanager_git.bb b/recipes-multimedia/audiomanager/audiomanager_git.bb
index 991cfb6..3b4c1a8 100644
--- a/recipes-multimedia/audiomanager/audiomanager_git.bb
+++ b/recipes-multimedia/audiomanager/audiomanager_git.bb
@@ -5,12 +5,13 @@ SECTION = "multimedia"
LICENSE = "MPLv2"
LIC_FILES_CHKSUM = "file://LICENCE;md5=815ca599c9df247a0c7f619bab123dad"
-PR = "r6"
+PR = "r7"
DEPENDS = "dlt-daemon sqlite3 dbus"
SRC_URI = "git://git.projects.genivi.org/AudioManager.git;protocol=git;tag=e33f72e932661784affc0f24d56f0e78fbac783f \
- file://AudioManager.service file://setup_amgr.sh"
+ file://AudioManager.service file://setup_amgr.sh \
+ file://0001-Build-plugins-as-modules-instead-of-shared-libraries.patch"
S = "${WORKDIR}/git"
inherit autotools gettext cmake pkgconfig systemd
@@ -23,16 +24,12 @@ DEFAULT_PREFERENCE = "-1"
EXTRA_OECMAKE += "-DWITH_TESTS=OFF -DUSE_BUILD_LIBS=OFF"
OECMAKE_CXX_FLAGS +="-ldl"
-FILES_${PN} += "${libdir}/audioManager/command/*.so.* \
- ${libdir}/audioManager/control/*.so.* \
- ${libdir}/audioManager/routing/*.so.* \
+FILES_${PN} += "${libdir}/audioManager/command/*.so* \
+ ${libdir}/audioManager/control/*.so* \
+ ${libdir}/audioManager/routing/*.so* \
${systemd_unitdir}/AudioManager.service \
${systemd_unitdir}/scripts/setup_amgr.sh \
"
-FILES_${PN}-dev += "${libdir}/audioManager/command/*.so \
- ${libdir}/audioManager/control/*.so \
- ${libdir}/audioManager/routing/*.so \
-"
FILES_${PN}-dbg += "${libdir}/audioManager/command/.debug/* \
${libdir}/audioManager/control/.debug/* \