aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins/make-host-always-use-64bit-tools.patch34
-rw-r--r--meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins_7.6.bb5
2 files changed, 37 insertions, 2 deletions
diff --git a/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins/make-host-always-use-64bit-tools.patch b/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins/make-host-always-use-64bit-tools.patch
new file mode 100644
index 0000000..f3dd97e
--- /dev/null
+++ b/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins/make-host-always-use-64bit-tools.patch
@@ -0,0 +1,34 @@
+diff --git a/PluginCommandInterfaceCAPI/cmake/CommonAPI.cmake b/PluginCommandInterfaceCAPI/cmake/CommonAPI.cmake
+index 3db1f4a..7b34223 100644
+--- a/PluginCommandInterfaceCAPI/cmake/CommonAPI.cmake
++++ b/PluginCommandInterfaceCAPI/cmake/CommonAPI.cmake
+@@ -119,11 +119,7 @@ ENDMACRO()
+
+ # helper function giving a string with the current architecture
+ function(GET_TARGET_ARCH OUT_ARCH)
+- IF(CMAKE_SIZEOF_VOID_P EQUAL 8)
+- SET(${OUT_ARCH} "x86_64" PARENT_SCOPE)
+- ELSE()
+- SET(${OUT_ARCH} "x86" PARENT_SCOPE)
+- ENDIF()
++ SET(${OUT_ARCH} "x86_64" PARENT_SCOPE)
+ endfunction()
+
+ # helper function giving a string with the current host
+diff --git a/PluginRoutingInterfaceCAPI/cmake/CommonAPI.cmake b/PluginRoutingInterfaceCAPI/cmake/CommonAPI.cmake
+index 3db1f4a..7b34223 100644
+--- a/PluginRoutingInterfaceCAPI/cmake/CommonAPI.cmake
++++ b/PluginRoutingInterfaceCAPI/cmake/CommonAPI.cmake
+@@ -119,11 +119,7 @@ ENDMACRO()
+
+ # helper function giving a string with the current architecture
+ function(GET_TARGET_ARCH OUT_ARCH)
+- IF(CMAKE_SIZEOF_VOID_P EQUAL 8)
+- SET(${OUT_ARCH} "x86_64" PARENT_SCOPE)
+- ELSE()
+- SET(${OUT_ARCH} "x86" PARENT_SCOPE)
+- ENDIF()
++ SET(${OUT_ARCH} "x86_64" PARENT_SCOPE)
+ endfunction()
+
+ # helper function giving a string with the current host
diff --git a/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins_7.6.bb b/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins_7.6.bb
index 4fd50ea..3e15ea0 100644
--- a/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins_7.6.bb
+++ b/meta-ivi/recipes-multimedia/audiomanager/audiomanagerplugins_7.6.bb
@@ -12,6 +12,7 @@ DEPENDS = "audiomanager capicxx-core-native capicxx-dbus-native python3 libxml2"
SRCREV = "03fa3696fbbc1d624095bfc60f80b9ec071bec07"
SRC_URI = " git://github.com/GENIVI/AudioManagerPlugins.git;protocol=https \
file://AM-Genivi-Filtering-out-JDK-warnings-in-CAPI-script.patch \
+ file://make-host-always-use-64bit-tools.patch \
"
S = "${WORKDIR}/git"
@@ -25,8 +26,8 @@ EXTRA_OECMAKE = " \
"
do_configure_prepend() {
- capi_core_home=$(dirname `find ${WORKDIR}/recipe-sysroot-native -name commonapi-generator-linux-x86`)
- capi_dbus_home=$(dirname `find ${WORKDIR}/recipe-sysroot-native -name commonapi-dbus-generator-linux-x86`)
+ capi_core_home=$(dirname `find ${WORKDIR}/recipe-sysroot-native -name commonapi-generator-linux-x86_64`)
+ capi_dbus_home=$(dirname `find ${WORKDIR}/recipe-sysroot-native -name commonapi-dbus-generator-linux-x86_64`)
if [ -L /usr/bin/java ]; then
java_bin=$(readlink -f /usr/bin/java)
if [ -L $java_bin ]; then