aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-selftest/images/secureboot-selftest-image-unsigned.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-selftest/images/secureboot-selftest-image-unsigned.bb')
-rw-r--r--recipes-selftest/images/secureboot-selftest-image-unsigned.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-selftest/images/secureboot-selftest-image-unsigned.bb b/recipes-selftest/images/secureboot-selftest-image-unsigned.bb
new file mode 100644
index 00000000..e03e7b47
--- /dev/null
+++ b/recipes-selftest/images/secureboot-selftest-image-unsigned.bb
@@ -0,0 +1,20 @@
+require recipes-core/images/core-image-minimal.bb
+
+DEPENDS_remove = "grub-efi"
+
+inherit uefi-comboapp
+
+WKS_FILE = "generic-bootdisk.wks.in"
+
+do_uefiapp_deploy_append() {
+ for i in ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.boot*.efi; do
+ target=`basename $i`
+ target=`echo $target | sed -e 's/${IMAGE_LINK_NAME}.//'`
+
+ cat > ${IMAGE_ROOTFS}/boot/startup.nsh << EOF
+$target
+reset
+EOF
+ break
+ done
+}