aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_4.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_4.19.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.19.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.19.bb b/recipes-kernel/linux/linux-intel-rt_4.19.bb
new file mode 100644
index 00000000..6b2825f6
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_4.19.bb
@@ -0,0 +1,24 @@
+require linux-intel.inc
+
+# Skip processing of this recipe if it is not explicitly specified as the
+# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
+# to build multiple virtual/kernel providers, e.g. as dependency of
+# core-image-rt-sdk, core-image-rt.
+python () {
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
+}
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
+
+KBRANCH = "4.19/preempt-rt"
+KMETA_BRANCH = "yocto-4.19"
+
+DEPENDS += "elfutils-native openssl-native util-linux-native"
+
+LINUX_VERSION ?= "4.19.13"
+SRCREV_machine ?= "135ff38d0e187434eb5fcf2c55087d1f0025d76f"
+SRCREV_meta ?= "ced14887c323f1cb6b3befe2b29e471e8fee1bc6"
+
+LINUX_KERNEL_TYPE = "preempt-rt"