summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-romley/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch')
-rw-r--r--meta-romley/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-romley/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch b/meta-romley/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
new file mode 100644
index 00000000..47b5ece7
--- /dev/null
+++ b/meta-romley/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
@@ -0,0 +1,35 @@
+From ea9a59b26c3c86b498337e968ee8f68c4e263614 Mon Sep 17 00:00:00 2001
+From: Olivier Matz <olivier.matz@6wind.com>
+Date: Fri, 16 May 2014 10:18:59 +0200
+Subject: [PATCH] examples/qos_sched: fix makefile
+
+Upstream-Status: backport
+Imported patch from: http://dpdk.org/browse/dpdk/log/
+
+The example does not compile as the linker complains about duplicated
+symbols.
+
+Remove -lsched from LDLIBS, it is already present in rte.app.mk and
+added by the DPDK framework automatically.
+
+Signed-off-by: Olivier Matz <olivier.matz@6wind.com>
+Acked-by: Thomas Monjalon <thomas.monjalon@6wind.com>
+Signed-off-by: Chan Wei Sern <wei.sern.chan@intel.com>
+---
+ examples/qos_sched/Makefile | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/examples/qos_sched/Makefile b/examples/qos_sched/Makefile
+index b91fe37..9366efe 100755
+--- a/examples/qos_sched/Makefile
++++ b/examples/qos_sched/Makefile
+@@ -54,6 +54,4 @@ CFLAGS += $(WERROR_FLAGS)
+ CFLAGS_args.o := -D_GNU_SOURCE
+ CFLAGS_cfg_file.o := -D_GNU_SOURCE
+
+-LDLIBS += -lrte_sched
+-
+ include $(RTE_SDK)/mk/rte.extapp.mk
+--
+1.9.1
+