aboutsummaryrefslogtreecommitdiffstats
path: root/meta-n450/recipes-bsp/audiofix/audiofix.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-n450/recipes-bsp/audiofix/audiofix.bb')
-rw-r--r--meta-n450/recipes-bsp/audiofix/audiofix.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-n450/recipes-bsp/audiofix/audiofix.bb b/meta-n450/recipes-bsp/audiofix/audiofix.bb
new file mode 100644
index 00000000..846d59ee
--- /dev/null
+++ b/meta-n450/recipes-bsp/audiofix/audiofix.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Provide a basic init script to enable audio"
+DESCRIPTION = "This package provides an init script which enables the audio on startup via the amixer command. It address a problem with the development board that has the audio muted on power on."
+SECTION = "base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r2"
+RDEPENDS = "amixer"
+
+SRC_URI = "file://n450_audiofix"
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/rc5.d
+ install -m 0755 ${WORKDIR}/n450_audiofix ${D}${sysconfdir}/init.d
+ ln -sf ../init.d/n450_audiofix ${D}/sysconfdir/rc5.d/S91n450_audiofix
+}