summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb58
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch43
-rw-r--r--common/recipes-core/zlib-qat-module/zlib-qat-module.bb52
-rw-r--r--common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch43
4 files changed, 0 insertions, 196 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
deleted file mode 100644
index 8b7ffb0c..00000000
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-SUMMARY = "libcrypto* (OpenSSL*) QAT_MEM Memory Management Module \
-for Intel Quick Assist Technology"
-DESCRIPTION = "This software adds an engine that accelerates some of \
-the libcrypto algorithms via the Intel QuickAssist Technology \
-implemented on Intel Communications Chipset 89xx Series based platforms."
-
-HOMEPAGE = "http://www.openssl.org/"
-SECTION = "libs/network"
-
-LICENSE = "openssl & GPLv2 & BSD"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/openssl-${PV}/LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8 \
- file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
- file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
-
-PV = "1.0.1"
-PR = "r0"
-
-OPENSSL_QAT_VERSION = "0.4.0-012"
-
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz;name=openssl \
- http://downloadmirror.intel.com/19368/eng/libcrypto-openssl-${PV}-qat.L.${OPENSSL_QAT_VERSION}.tar.gz;name=libcrypto \
- file://openssl_qat_module.patch"
-
-SRC_URI[openssl.md5sum]="134f168bc2a8333f19f81d684841710b"
-SRC_URI[openssl.sha256sum]="4d9f0a594a9a89b28e1a04a9504c04104f6508ee27ad1e0efdd17a7a6dbbeeee"
-
-SRC_URI[libcrypto.md5sum] = "e4e131fa56d3aa1a52b5bdb9f8fe5a69"
-SRC_URI[libcrypto.sha256sum] = "19a80ae6e78548934295d312148e4254c18dabd25e2fd72de5796d8ac15b1cfb"
-
-COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
-
-S = "${WORKDIR}/openssl-${PV}/engines/qat_engine/qat_mem"
-
-export KERNEL_SOURCE_ROOT = "${STAGING_KERNEL_DIR}"
-inherit module
-
-do_patch() {
- cd ${WORKDIR}/openssl-${PV}
- patch -p2 < ${WORKDIR}/libcrypto-openssl-${PV}-qat.L.${OPENSSL_QAT_VERSION}.patch
-
- cd ${WORKDIR}
- patch -p1 <${WORKDIR}/openssl_qat_module.patch
-}
-
-do_compile() {
- cd ${S}
- oe_runmake KERNEL_CC="${KERNEL_CC}"
-}
-
-do_install_append() {
- install -m 0755 -d ${D}${bindir} \
- ${D}${includedir}/engines/qat_engine/qat_mem
-
- install -m 0755 ${S}/qat_mem_test ${D}${bindir}
- install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/
-}
-
-FILES_${PN} += "${bindir}/qat_mem_test"
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
deleted file mode 100644
index dfed3c08..00000000
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Index: openssl-qat-module-1.0.1-r0/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile
-===================================================================
---- openssl-qat-module-1.0.1-r0.orig/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile 2012-10-17 13:31:27.932376960 -0700
-+++ openssl-qat-module-1.0.1-r0/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile 2012-10-17 13:35:40.396389410 -0700
-@@ -9,13 +9,9 @@
- MODULENAME := qat_mem
- ### should not need to change stuff below ######################
-
--
--KDIR := /lib/modules/$(shell uname -r)/build
--#KDIR := /exports/linux-2.6.12.2/
-+KDIR := $(KERNEL_SOURCE_ROOT)
- PWD := $(shell pwd)
--
--CC := gcc -Wall -imacros /usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
--
-+CC := $(KERNEL_CC) -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
- ifeq ($(KERNELRELEASE),)
- all: $(MODULENAME)_test
- all:
-@@ -23,20 +19,15 @@
- else
- obj-m := $(MODULENAME).o
- endif
--
- $(MODULENAME)_test: $(MODULENAME)_test.c
- $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
--
--
-+modules_install:
-+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
- load:
- insmod ./$(MODULENAME).ko
--
- unload:
- rmmod $(MODULENAME)
--
- test: all
- ./$(MODULENAME)_test.sh
--
- clean:
- rm -f *.o *.ko Modules.symvers *.mod.c .*.cmd $(MODULENAME)_test
--
diff --git a/common/recipes-core/zlib-qat-module/zlib-qat-module.bb b/common/recipes-core/zlib-qat-module/zlib-qat-module.bb
deleted file mode 100644
index 5ade06eb..00000000
--- a/common/recipes-core/zlib-qat-module/zlib-qat-module.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-SUMMARY="Zlib QAT_MEM Memory Management Module for Intel Quick Assist \
-Technology"
-DESCRIPTION="This software acelerates the data compression algorithm \
-in the zlib software library via the Intel QuickAssist Technology \
-implemented on Intel Communications Chipset 89xx Series based platforms."
-
-HOMEPAGE = "http://zlib.net/"
-SECTION = "libs"
-LICENSE = "Zlib & GPLv2 & BSD"
-
-LIC_FILES_CHKSUM = "file://${WORKDIR}/zlib-${PV}/zlib.h;beginline=4;endline=23;md5=94d1b5a40dadd127f3351471727e66a9 \
- file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
- file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
-PV = "1.2.7"
-ZLIB_QAT_VERSION = "0.4.0-011"
-
-PR="r0"
-
-SRC_URI = "http://www.zlib.net/zlib-${PV}.tar.gz;name=zlib \
- http://downloadmirror.intel.com/20294/eng/zlib-${PV}-qat.L.${ZLIB_QAT_VERSION}.tar.gz;name=zlib_qat \
- file://zlib_qat_module.patch"
-
-SRC_URI[zlib.md5sum]="60df6a37c56e7c1366cca812414f7b85"
-SRC_URI[zlib.sha256sum]="fa9c9c8638efb8cb8ef5e4dd5453e455751e1c530b1595eed466e1be9b7e26c5"
-
-SRC_URI[zlib_qat.md5sum]="88e4140f98d2f9e170bf473f20e1a8d4"
-SRC_URI[zlib_qat.sha256sum]="3c360878127f3930e64640ef5a5822719a5059143326bb4c396645ae37b704a6"
-
-S = "${WORKDIR}/zlib-${PV}/contrib/qat/qat_mem"
-
-inherit module
-export KERNEL_SOURCE_ROOT = "${STAGING_KERNEL_DIR}"
-
-do_patch() {
- cd ${WORKDIR}/zlib-${PV}
- patch -p0 < ${WORKDIR}/zlib-${PV}-qat.L.${ZLIB_QAT_VERSION}.patch
-
- cd ${WORKDIR}
- patch -p1 < ${WORKDIR}/zlib_qat_module.patch
-}
-
-do_compile() {
- cd ${S}
- oe_runmake KERNEL_CC="${KERNEL_CC}"
-}
-
-do_install_append() {
- install -m 0755 -d ${D}${bindir}
- install -m 0755 ${S}/qat_mem_test ${D}${bindir}
-}
-
-FILES_${PN} += "${bindir}/qat_mem_test"
diff --git a/common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch b/common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch
deleted file mode 100644
index a30f8b05..00000000
--- a/common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Index: zlib-qat-module-1.2.7-r0/zlib-1.2.7/contrib/qat/qat_mem/Makefile
-===================================================================
---- zlib-qat-module-1.2.7-r0.orig/zlib-1.2.7/contrib/qat/qat_mem/Makefile 2012-10-16 13:53:10.258938722 -0700
-+++ zlib-qat-module-1.2.7-r0/zlib-1.2.7/contrib/qat/qat_mem/Makefile 2012-10-16 13:59:18.174944864 -0700
-@@ -59,13 +59,10 @@
- #
- #
- #########################################################################
--
- MODULENAME := qat_mem
--KDIR := /lib/modules/$(shell uname -r)/build
-+KDIR := $(KERNEL_SOURCE_ROOT)
- PWD := $(shell pwd)
--
--CC := gcc -Wall -imacros /usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
--
-+CC := $(KERNEL_CC) -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
- ifeq ($(KERNELRELEASE),)
- all: $(MODULENAME)_test
- all:
-@@ -73,20 +70,15 @@
- else
- obj-m := $(MODULENAME).o
- endif
--
-+modules_install:
-+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
- $(MODULENAME)_test: $(MODULENAME)_test.c
- $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
--
--
- load:
- insmod ./$(MODULENAME).ko
--
- unload:
- rmmod $(MODULENAME)
--
- test: all
- ./$(MODULENAME)_test
--
- clean:
- rm -f *.o *.ko Module.symvers modules.order *.mod.c .*.cmd $(MODULENAME)_test
--