summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/systemd-boot/systemd-boot.bbappend')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot.bbappend11
1 files changed, 7 insertions, 4 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
index 0da0c46a..ed317554 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
+++ b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
@@ -1,8 +1,8 @@
-DEPENDS += "rmc"
+DEPENDS_append_intel-x86-common = " rmc"
FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-boot:"
-EXTRA_OEMAKE += 'EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc/efi -DRMC_EFI"'
+EXTRA_OEMAKE_append_intel-x86-common = ' EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc/efi -DRMC_EFI"'
# Pin systemd revision down for systemd-boot recipe.
# Patches could not be applied cleanly when systemd in OE is updated,
@@ -12,10 +12,13 @@ EXTRA_OEMAKE += 'EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STA
# resolving conflicts for a new tip could be done in a short time.
# Revision: systemd 230 in OE
-SRCREV = "3a74d4fc90cb322a4784a3515bef7118c8f8c5ba"
+SRCREV_intel-x86-common = "3a74d4fc90cb322a4784a3515bef7118c8f8c5ba"
-SRC_URI += "file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \
+SRC_URI_append_intel-x86-common = " \
+ file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \
file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \
file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \
file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \
"
+
+PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"