aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend11
1 files changed, 5 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index c87a7e25..5c5c96e1 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -10,12 +10,12 @@ SRCREV_meta_core2-32-intel-common ?= "20edcbf4e42dd4cef7213a0ce2a4481d8d296f5d"
SRCREV_machine_core2-32-intel-common ?= "9195020e5747fba069c19996fab079931584a7fb"
KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
-LINUX_VERSION_corei7-64-intel-common = "4.1.26"
+LINUX_VERSION_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', '4.1.27', '4.1.26', d)}"
COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
-KMACHINE_corei7-64-intel-common = "intel-corei7-64"
-KBRANCH_corei7-64-intel-common = "standard/intel/base"
-SRCREV_meta_corei7-64-intel-common ?= "20edcbf4e42dd4cef7213a0ce2a4481d8d296f5d"
-SRCREV_machine_corei7-64-intel-common ?= "9195020e5747fba069c19996fab079931584a7fb"
+KMACHINE_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'leafhill', 'intel-corei7-64', d)}"
+KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'standard/intel/4.1.27/leaf-hill', 'standard/intel/base', d)}"
+SRCREV_meta_corei7-64-intel-common ?= "cf6d9876629270e8ed99541db252840291d03f5a"
+SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', '41fc98f785ad56f0df1b85ac039bd5e391697842', '9195020e5747fba069c19996fab079931584a7fb', d)}"
KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
# Quark / X1000 BSP Info
@@ -27,7 +27,6 @@ SRCREV_meta_i586-nlp-32-intel-common ?= "20edcbf4e42dd4cef7213a0ce2a4481d8d296f5
SRCREV_machine_i586-nlp-32-intel-common ?= "9195020e5747fba069c19996fab079931584a7fb"
KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
-
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"