aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-crownbay/conf/layer.conf6
-rw-r--r--meta-crownbay/conf/machine/crownbay-noemgd.conf45
-rw-r--r--meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig3
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf26
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend4
5 files changed, 83 insertions, 1 deletions
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf
index 52581e1c..cee4ba24 100644
--- a/meta-crownbay/conf/layer.conf
+++ b/meta-crownbay/conf/layer.conf
@@ -5,6 +5,10 @@ BBPATH := "${BBPATH}:${LAYERDIR}"
BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
-BBFILE_COLLECTIONS += "crownbay"
+BBFILE_COLLECTIONS_crownbay += "crownbay"
BBFILE_PATTERN_crownbay := "^${LAYERDIR}/"
BBFILE_PRIORITY_crownbay = "6"
+
+BBFILE_COLLECTIONS_crownbay-noemgd += "crownbay-noemgd"
+BBFILE_PATTERN_crownbay-noemgd := "^${LAYERDIR}/"
+BBFILE_PRIORITY_crownbay-noemgd = "6"
diff --git a/meta-crownbay/conf/machine/crownbay-noemgd.conf b/meta-crownbay/conf/machine/crownbay-noemgd.conf
new file mode 100644
index 00000000..535cf55e
--- /dev/null
+++ b/meta-crownbay/conf/machine/crownbay-noemgd.conf
@@ -0,0 +1,45 @@
+#@TYPE: Machine
+#@NAME: crownbay-noemgd
+
+#@DESCRIPTION: Machine configuration for Crown Bay systems, without Intel-proprietary graphics bits
+# i.e. E660 + EG20T
+
+TARGET_ARCH = "i586"
+PACKAGE_EXTRA_ARCHS = "x86 atom"
+
+include conf/machine/include/tune-atom.inc
+
+BASE_PACKAGE_ARCH="atom"
+
+MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
+ acpi serial usbgadget"
+
+KERNEL_IMAGETYPE = "bzImage"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-wrs"
+PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
+PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
+XSERVER ?= "xserver-xf86-dri-lite \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+ xf86-input-evdev \
+ xf86-input-synaptics \
+ xf86-video-vesa"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
+
+GUI_MACHINE_CLASS = "bigscreen"
+
+IMAGE_ROOTFS_SIZE_ext3 = "2000000"
+
+IMAGE_FSTYPES ?= "ext3 cpio.gz"
+
+GLIBC_ADDONS = "nptl"
+GLIBC_EXTRA_OECONF = "--with-tls"
+
+SRCREV_machine_pn-linux-wrs_crownbay-noemgd = "f0afe10edaed24575eb115ad69c366fc24ea9380"
+SRCREV_meta_pn-linux-wrs = "2f315f96f26a93d22fe0fc524de629e7c46b8469"
diff --git a/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
@@ -0,0 +1,3 @@
+# Assume a USB mouse and keyboard are connected
+HAVE_TOUCHSCREEN=0
+HAVE_KEYBOARD=1
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf
new file mode 100644
index 00000000..da4fc3c6
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf
@@ -0,0 +1,26 @@
+Section "Device"
+ Identifier "Generic VESA"
+ Driver "vesa"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ Option "DPMS"
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Generic VESA"
+ Monitor "Generic Monitor"
+ DefaultDepth 24
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+EndSection
+
+Section "ServerFlags"
+ Option "DontZap" "0"
+ Option "AutoAddDevices" "False"
+EndSection
diff --git a/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend b/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend
index 9709c365..aebe789a 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend
@@ -1,3 +1,7 @@
FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
COMPATIBLE_MACHINE_crownbay = "crownbay"
WRMACHINE_crownbay = "crownbay"
+
+COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
+WRMACHINE_crownbay-noemgd = "crownbay"