summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend27
1 files changed, 23 insertions, 4 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
index 90e43944..6bfa9686 100644
--- a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
+++ b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
@@ -1,5 +1,24 @@
-# Temporary avoid warnings of duplicate files providers until
-# mesa-dri & emgd-driver-bin recipes are fixed
-SSTATE_DUPWHITELIST += "${STAGING_INCDIR}/KHR ${STAGING_INCDIR}/EGL \
- ${STAGING_INCDIR}/GLES ${STAGING_INCDIR}/GLES2"
+# The emgd binary driver also provides egl, gles1, gles2 library & headers.
+# To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image
+# is bundling the emgd driver.
+
+python __anonymous () {
+ import re
+ xserver = d.getVar('XSERVER', True)
+ if 'emgd-driver-bin' in xserver.split(' '):
+ extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
+ take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"]
+ put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"]
+ pattern = re.compile("--with-egl-platforms")
+ new_extra_oeconf = [ ]
+ for i in extra_oeconf:
+ if ( i not in take_out ) and ( not pattern.match(i)):
+ new_extra_oeconf.append(i)
+ for i in put_in:
+ new_extra_oeconf.append(i)
+
+ d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
+ depends = d.getVar('DEPENDS', True)
+ d.setVar('DEPENDS', depends + " emgd-driver-bin")
+}