summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state411
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state411
3 files changed, 823 insertions, 0 deletions
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend
new file mode 100644
index 00000000..72d991c7
--- /dev/null
+++ b/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state
new file mode 100644
index 00000000..8a89f0bc
--- /dev/null
+++ b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state
@@ -0,0 +1,411 @@
+state.MID {
+ control.1 {
+ iface MIXER
+ name 'PCM Playback Volume'
+ value.0 24
+ value.1 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -900
+ dbvalue.1 -900
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'PCM Playback Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Headphone Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -4500
+ dbvalue.1 -4500
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Headphone Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'Rear Mic Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'Rear Mic Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.7 {
+ iface MIXER
+ name 'Front Mic Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.8 {
+ iface MIXER
+ name 'Front Mic Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.9 {
+ iface MIXER
+ name 'Line Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.10 {
+ iface MIXER
+ name 'Line Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.11 {
+ iface MIXER
+ name 'CD Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.12 {
+ iface MIXER
+ name 'CD Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.13 {
+ iface MIXER
+ name 'Auto-Mute Mode'
+ value Disabled
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Disabled
+ item.1 Enabled
+ }
+ }
+ control.14 {
+ iface MIXER
+ name 'Rear Mic Boost Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 3'
+ dbmin 0
+ dbmax 3000
+ dbvalue.0 0
+ dbvalue.1 0
+ }
+ }
+ control.15 {
+ iface MIXER
+ name 'Front Mic Boost Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 3'
+ dbmin 0
+ dbmax 3000
+ dbvalue.0 0
+ dbvalue.1 0
+ }
+ }
+ control.16 {
+ iface MIXER
+ name 'Capture Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.17 {
+ iface MIXER
+ name 'Capture Switch'
+ index 1
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.18 {
+ iface MIXER
+ name 'Capture Switch'
+ index 2
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.19 {
+ iface MIXER
+ name 'Capture Volume'
+ value.0 25
+ value.1 25
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 2550
+ dbvalue.1 2550
+ }
+ }
+ control.20 {
+ iface MIXER
+ name 'Capture Volume'
+ index 1
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 -1200
+ dbvalue.1 -1200
+ }
+ }
+ control.21 {
+ iface MIXER
+ name 'Capture Volume'
+ index 2
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 -1200
+ dbvalue.1 -1200
+ }
+ }
+ control.22 {
+ iface MIXER
+ name 'Input Source'
+ value Line
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Rear Mic'
+ item.1 'Front Mic'
+ item.2 Line
+ item.3 CD
+ }
+ }
+ control.23 {
+ iface MIXER
+ name 'Input Source'
+ index 1
+ value 'Rear Mic'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Rear Mic'
+ item.1 'Front Mic'
+ item.2 Line
+ item.3 CD
+ }
+ }
+ control.24 {
+ iface MIXER
+ name 'Input Source'
+ index 2
+ value 'Rear Mic'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Rear Mic'
+ item.1 'Front Mic'
+ item.2 Line
+ item.3 CD
+ }
+ }
+ control.25 {
+ iface MIXER
+ name 'IEC958 Playback Con Mask'
+ value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
+ comment {
+ access read
+ type IEC958
+ count 1
+ }
+ }
+ control.26 {
+ iface MIXER
+ name 'IEC958 Playback Pro Mask'
+ value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
+ comment {
+ access read
+ type IEC958
+ count 1
+ }
+ }
+ control.27 {
+ iface MIXER
+ name 'IEC958 Playback Default'
+ value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
+ comment {
+ access 'read write'
+ type IEC958
+ count 1
+ }
+ }
+ control.28 {
+ iface MIXER
+ name 'IEC958 Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.29 {
+ iface MIXER
+ name 'IEC958 Default PCM Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.30 {
+ iface MIXER
+ name 'Master Playback Volume'
+ value 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -900
+ }
+ }
+ control.31 {
+ iface MIXER
+ name 'Master Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+}
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state
new file mode 100644
index 00000000..8a89f0bc
--- /dev/null
+++ b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state
@@ -0,0 +1,411 @@
+state.MID {
+ control.1 {
+ iface MIXER
+ name 'PCM Playback Volume'
+ value.0 24
+ value.1 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -900
+ dbvalue.1 -900
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'PCM Playback Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Headphone Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -4500
+ dbvalue.1 -4500
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Headphone Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'Rear Mic Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'Rear Mic Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.7 {
+ iface MIXER
+ name 'Front Mic Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.8 {
+ iface MIXER
+ name 'Front Mic Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.9 {
+ iface MIXER
+ name 'Line Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.10 {
+ iface MIXER
+ name 'Line Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.11 {
+ iface MIXER
+ name 'CD Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 -3450
+ dbvalue.1 -3450
+ }
+ }
+ control.12 {
+ iface MIXER
+ name 'CD Playback Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.13 {
+ iface MIXER
+ name 'Auto-Mute Mode'
+ value Disabled
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Disabled
+ item.1 Enabled
+ }
+ }
+ control.14 {
+ iface MIXER
+ name 'Rear Mic Boost Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 3'
+ dbmin 0
+ dbmax 3000
+ dbvalue.0 0
+ dbvalue.1 0
+ }
+ }
+ control.15 {
+ iface MIXER
+ name 'Front Mic Boost Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 3'
+ dbmin 0
+ dbmax 3000
+ dbvalue.0 0
+ dbvalue.1 0
+ }
+ }
+ control.16 {
+ iface MIXER
+ name 'Capture Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.17 {
+ iface MIXER
+ name 'Capture Switch'
+ index 1
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.18 {
+ iface MIXER
+ name 'Capture Switch'
+ index 2
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.19 {
+ iface MIXER
+ name 'Capture Volume'
+ value.0 25
+ value.1 25
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 2550
+ dbvalue.1 2550
+ }
+ }
+ control.20 {
+ iface MIXER
+ name 'Capture Volume'
+ index 1
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 -1200
+ dbvalue.1 -1200
+ }
+ }
+ control.21 {
+ iface MIXER
+ name 'Capture Volume'
+ index 2
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 -1200
+ dbvalue.1 -1200
+ }
+ }
+ control.22 {
+ iface MIXER
+ name 'Input Source'
+ value Line
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Rear Mic'
+ item.1 'Front Mic'
+ item.2 Line
+ item.3 CD
+ }
+ }
+ control.23 {
+ iface MIXER
+ name 'Input Source'
+ index 1
+ value 'Rear Mic'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Rear Mic'
+ item.1 'Front Mic'
+ item.2 Line
+ item.3 CD
+ }
+ }
+ control.24 {
+ iface MIXER
+ name 'Input Source'
+ index 2
+ value 'Rear Mic'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Rear Mic'
+ item.1 'Front Mic'
+ item.2 Line
+ item.3 CD
+ }
+ }
+ control.25 {
+ iface MIXER
+ name 'IEC958 Playback Con Mask'
+ value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
+ comment {
+ access read
+ type IEC958
+ count 1
+ }
+ }
+ control.26 {
+ iface MIXER
+ name 'IEC958 Playback Pro Mask'
+ value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
+ comment {
+ access read
+ type IEC958
+ count 1
+ }
+ }
+ control.27 {
+ iface MIXER
+ name 'IEC958 Playback Default'
+ value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
+ comment {
+ access 'read write'
+ type IEC958
+ count 1
+ }
+ }
+ control.28 {
+ iface MIXER
+ name 'IEC958 Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.29 {
+ iface MIXER
+ name 'IEC958 Default PCM Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.30 {
+ iface MIXER
+ name 'Master Playback Volume'
+ value 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -900
+ }
+ }
+ control.31 {
+ iface MIXER
+ name 'Master Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+}