aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-11 17:35:16 +0100
committerTom Zanussi <tom.zanussi@linux.intel.com>2013-09-11 11:59:36 -0500
commit4f5c753fb2db0cb1f6989ea3be270eebf3ea3572 (patch)
tree84d6ef0f207fea877286aaaf6029ba0c48921de4
parent78f83fed4fbd6e7f0af0edabf6a90d91d61a4237 (diff)
downloadmeta-intel-4f5c753fb2db0cb1f6989ea3be270eebf3ea3572.tar.gz
meta-intel-4f5c753fb2db0cb1f6989ea3be270eebf3ea3572.tar.bz2
meta-intel-4f5c753fb2db0cb1f6989ea3be270eebf3ea3572.zip
emgd-driver-bin: Fix RDEPENDS and exclude from world1.5_M5.rc1
One of the drivers links to libva so we need to list it as an RDEPENDS so that when we package, we can ensure any library renaming gets applied correctly. The bug can be seen if you "bitbake emgd-driver-bin", then build an image using that library. Also exclude these recipes from world since they should get built when needed through the virtual/ mechanism, building them for say a qemux86 world build just corrupts the system due the the multiple shlibs providers. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Reviewed-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb5
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb5
2 files changed, 10 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
index 4cb7b8a0..6778ee0d 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.16.bb
@@ -18,6 +18,11 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/${EMGD_LIC_DIR}/License.txt;md5=b54f01caaf
DEPENDS = "rpm-native xz-native"
RDEPENDS_${PN} = "libxcb-dri2 cairo xserver-xorg"
+RDEPENDS_emgd-gst-plugins-mixvideo = "libva-tpi"
+
+# These libraries shouldn't get installed in world builds unless something
+# explicitly depends upon them.
+EXCLUDE_FROM_WORLD = "1"
# Add the ABI dependency at package generation time, as otherwise bitbake will
# attempt to find a provider for it (and fail) when it does the parse.
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
index b659a8b4..ee4a313c 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.18.bb
@@ -18,6 +18,11 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/${EMGD_LIC_DIR}/License.txt;md5=7ce256e6a3
DEPENDS = "rpm-native xz-native"
RDEPENDS_${PN} = "libxcb-dri2 cairo xserver-xorg"
+RDEPENDS_emgd-gst-plugins-mixvideo = "libva-tpi"
+
+# These libraries shouldn't get installed in world builds unless something
+# explicitly depends upon them.
+EXCLUDE_FROM_WORLD = "1"
# Add the ABI dependency at package generation time, as otherwise bitbake will
# attempt to find a provider for it (and fail) when it does the parse.