aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/files/0001-libtraceevent-Remove-hard-coded-include-to-usr-local.patch37
-rw-r--r--recipes-kernel/linux/linux-yocto-clanton_3.8.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/0001-libtraceevent-Remove-hard-coded-include-to-usr-local.patch b/recipes-kernel/linux/files/0001-libtraceevent-Remove-hard-coded-include-to-usr-local.patch
new file mode 100644
index 0000000..c11ead3
--- /dev/null
+++ b/recipes-kernel/linux/files/0001-libtraceevent-Remove-hard-coded-include-to-usr-local.patch
@@ -0,0 +1,37 @@
+From b9e8c37220c80e78289a1e87b50c09418eb59a7e Mon Sep 17 00:00:00 2001
+From: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
+Date: Fri, 8 Mar 2013 11:21:52 +0000
+Subject: [PATCH] libtraceevent: Remove hard coded include to
+ /usr/local/include in Makefile
+
+having /usr/local/include hardcoded into the makefile is not necessary
+as this is automatically included by GCC. It also infects cross-compile
+builds with the host systems includes.
+
+Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
+Acked-by: Namhyung Kim <namhyung@kernel.org>
+Cc: Ingo Molnar <mingo@redhat.com>
+Cc: Paul Mackerras <paulus@samba.org>
+Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
+Link: http://lkml.kernel.org/r/1362741712-21308-1-git-send-email-ml@communistcode.co.uk
+Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+---
+ tools/lib/traceevent/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/lib/traceevent/Makefile b/tools/lib/traceevent/Makefile
+index a20e320..0b0a907 100644
+--- a/tools/lib/traceevent/Makefile
++++ b/tools/lib/traceevent/Makefile
+@@ -122,7 +122,7 @@ export Q VERBOSE
+
+ EVENT_PARSE_VERSION = $(EP_VERSION).$(EP_PATCHLEVEL).$(EP_EXTRAVERSION)
+
+-INCLUDES = -I. -I/usr/local/include $(CONFIG_INCLUDES)
++INCLUDES = -I. $(CONFIG_INCLUDES)
+
+ # Set compile option CFLAGS if not set elsewhere
+ CFLAGS ?= -g -Wall
+--
+1.8.5.3
+
diff --git a/recipes-kernel/linux/linux-yocto-clanton_3.8.bb b/recipes-kernel/linux/linux-yocto-clanton_3.8.bb
index 135338d..e6b23e9 100644
--- a/recipes-kernel/linux/linux-yocto-clanton_3.8.bb
+++ b/recipes-kernel/linux/linux-yocto-clanton_3.8.bb
@@ -51,6 +51,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git
SRC_URI += "file://clanton.patch"
SRC_URI += "file://clanton.cfg"
SRC_URI += "file://clanton-standard.scc"
+SRC_URI += "file://0001-libtraceevent-Remove-hard-coded-include-to-usr-local.patch"
LINUX_VERSION ?= "3.8"
LINUX_VERSION_EXTENSION ?= "-clanton"