aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files/features/perf/perf-use-pkg-config-instead-of-python-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/files/features/perf/perf-use-pkg-config-instead-of-python-config.patch')
-rw-r--r--recipes-kernel/linux/files/features/perf/perf-use-pkg-config-instead-of-python-config.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/features/perf/perf-use-pkg-config-instead-of-python-config.patch b/recipes-kernel/linux/files/features/perf/perf-use-pkg-config-instead-of-python-config.patch
new file mode 100644
index 0000000..26b0787
--- /dev/null
+++ b/recipes-kernel/linux/files/features/perf/perf-use-pkg-config-instead-of-python-config.patch
@@ -0,0 +1,33 @@
+From b4bc86501882e4c62042afd7fc8072a5bb7bcb3c Mon Sep 17 00:00:00 2001
+From: Tom Zanussi <tom.zanussi@intel.com>
+Date: Tue, 3 Jul 2012 13:07:21 -0500
+Subject: [PATCH 1/3] perf: use pkg-config instead of python-config
+
+Python has build flags available via pkg-config, use those at
+build-time instead.
+
+Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
+---
+ tools/perf/Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/perf/Makefile b/tools/perf/Makefile
+index 92271d3..35425ab 100644
+--- a/tools/perf/Makefile
++++ b/tools/perf/Makefile
+@@ -596,10 +596,10 @@ else
+
+ PYTHON_CONFIG_SQ := $(call shell-sq,$(PYTHON_CONFIG))
+
+- PYTHON_EMBED_LDOPTS := $(shell $(PYTHON_CONFIG_SQ) --ldflags 2>/dev/null)
++ PYTHON_EMBED_LDOPTS := $(shell pkg-config --libs python 2>/dev/null)
+ PYTHON_EMBED_LDFLAGS := $(call strip-libs,$(PYTHON_EMBED_LDOPTS))
+ PYTHON_EMBED_LIBADD := $(call grep-libs,$(PYTHON_EMBED_LDOPTS))
+- PYTHON_EMBED_CCOPTS := $(shell $(PYTHON_CONFIG_SQ) --cflags 2>/dev/null)
++ PYTHON_EMBED_CCOPTS := $(shell pkg-config --cflags python 2>/dev/null)
+ FLAGS_PYTHON_EMBED := $(PYTHON_EMBED_CCOPTS) $(PYTHON_EMBED_LDOPTS)
+
+ ifneq ($(call try-cc,$(SOURCE_PYTHON_EMBED),$(FLAGS_PYTHON_EMBED)),y)
+--
+1.7.5.4
+