aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/grub/grub_0.97.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-bsp/grub/grub_0.97.bb b/recipes-bsp/grub/grub_0.97.bb
index 9429052..82563e4 100644
--- a/recipes-bsp/grub/grub_0.97.bb
+++ b/recipes-bsp/grub/grub_0.97.bb
@@ -21,7 +21,12 @@ SRC_URI = "git://github.com/vathpela/grub-fedora.git"
SRC_URI += "file://quark.patch"
-CFLAGS_append = " -Os -fno-strict-aliasing -Wall -Werror -Wno-shadow -Wno-unused -Wno-pointer-sign "
+# To build GRUB with test code automatically loaded, simply uncomment this line
+# or add PACKAGECONFIG_pn-grub="grub_test" under conf/local.conf
+#PACKAGECONFIG ?= "grub_test"
+
+CFLAGS_append = " -Os -fno-strict-aliasing -Wall -Werror -Wno-shadow -Wno-unused -Wno-pointer-sign \
+ -DINTEL_QUARK_TEST=${@base_contains('PACKAGECONFIG', 'grub_test', '1', '0', d)}"
S = "${WORKDIR}/git"
SEPB = "${S}"