summaryrefslogtreecommitdiffstats
path: root/recipes-sato
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sato')
-rw-r--r--recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch24
-rw-r--r--recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb2
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch b/recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch
new file mode 100644
index 0000000..408d6a0
--- /dev/null
+++ b/recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch
@@ -0,0 +1,24 @@
+From a92a8b8e7a197a112f41e41ccac77541fd887eb9 Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Thu, 26 Apr 2018 01:25:06 +0200
+Subject: [PATCH] libptytty: Correct a typo to make it build with C++11
+
+Upstream-Status: Backport
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ libptytty/src/estl.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libptytty/src/estl.h b/libptytty/src/estl.h
+index 9552238..4e47392 100644
+--- a/libptytty/src/estl.h
++++ b/libptytty/src/estl.h
+@@ -67,7 +67,7 @@ private:
+ {
+ #if __cplusplus >= 201103L
+ return std::is_trivially_assignable<T, T>::value
+- && std::is_trivially_constructable<T>::value
++ && std::is_trivially_constructible<T>::value
+ && std::is_trivially_copyable<T>::value
+ && std::is_trivially_destructible<T>::value;
+ #elif ECB_GCC_VERSION(4,4)
diff --git a/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb b/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb
index 3480ec7..1f83559 100644
--- a/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb
+++ b/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb
@@ -4,5 +4,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432"
+SRC_URI += "file://0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch"
+
SRC_URI[md5sum] = "4a5b823f08d21036f94a6c51e94d025b"
SRC_URI[sha256sum] = "e73e13fe64b59fd3c8e6e20c00f149d388741f141b8155e4700d3ed40aa94b4e"