summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch')
-rw-r--r--recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch b/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch
new file mode 100644
index 0000000..755be0b
--- /dev/null
+++ b/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch
@@ -0,0 +1,36 @@
+From 9858702dbd1e137262c06765919937660879f63c Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Sun, 24 Sep 2017 09:12:58 -0400
+Subject: [PATCH 2/2] glob: Do not assume glibc glob internals.
+
+It has been proposed that glibc glob start using gl_lstat,
+which the API allows it to do. GNU 'make' should not get in
+the way of this. See:
+https://sourceware.org/ml/libc-alpha/2017-09/msg00409.html
+
+* dir.c (local_lstat): New function, like local_stat.
+(dir_setup_glob): Use it to initialize gl_lstat too, as the API
+requires.
+---
+Upstream-Status: Backport
+which is so small that it's effectively public domain.
+
+ configure.ac | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+Index: make-3.81/configure.in
+===================================================================
+--- make-3.81.orig/configure.in
++++ make-3.81/configure.in
+@@ -348,10 +348,9 @@ AC_CACHE_VAL(make_cv_sys_gnu_glob, [
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif