summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch32
-rw-r--r--recipes-extended/diffutils/diffutils_2.8.1.bb4
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch b/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch
new file mode 100644
index 0000000..dc03aa6
--- /dev/null
+++ b/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch
@@ -0,0 +1,32 @@
+From 7448c928240aafbfec08a92530a150bc206673bf Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Thu, 26 Apr 2018 02:40:52 +0200
+Subject: [PATCH] Make it build with compile time hardening enabled
+
+This avoids the following error:
+
+ src/diff3.c: In function 'output_diff3':
+ src/diff3.c:1405:5: error: format not a string literal and no format
+ arguments [-Werror=format-security]
+ fprintf (outputfile, line_prefix);
+ ^~~~~~~
+
+Upstream-Status: Inappropriate [legacy version]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ src/diff3.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/diff3.c b/src/diff3.c
+index f3d3dcf..7237dea 100644
+--- a/src/diff3.c
++++ b/src/diff3.c
+@@ -1402,7 +1402,7 @@ output_diff3 (FILE *outputfile, struct diff3_block *diff,
+ line = 0;
+ do
+ {
+- fprintf (outputfile, line_prefix);
++ fprintf (outputfile, "%s", line_prefix);
+ cp = D_RELNUM (ptr, realfile, line);
+ length = D_RELLEN (ptr, realfile, line);
+ fwrite (cp, sizeof (char), length, outputfile);
diff --git a/recipes-extended/diffutils/diffutils_2.8.1.bb b/recipes-extended/diffutils/diffutils_2.8.1.bb
index fe56f9c..466bf28 100644
--- a/recipes-extended/diffutils/diffutils_2.8.1.bb
+++ b/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -7,7 +7,9 @@ PR = "r7.0"
SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
file://diffutils_fix_for_automake-1.12.patch \
- file://fix_gcc6.patch"
+ file://fix_gcc6.patch \
+ file://0001-Make-it-build-with-compile-time-hardening-enabled.patch \
+ "
SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428"
SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a"