aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-19 17:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-19 21:47:15 +0100
commite4da38dd796b258a1b7c82221e03c0033092a8ba (patch)
treec2abd80899ebeb781cbc28743734fd8b9a349618
parent9e119f333cc8f53bd3cf64326f826dbc6ce3db0f (diff)
downloadmeta-gplv2-e4da38dd796b258a1b7c82221e03c0033092a8ba.tar.gz
meta-gplv2-e4da38dd796b258a1b7c82221e03c0033092a8ba.tar.bz2
meta-gplv2-e4da38dd796b258a1b7c82221e03c0033092a8ba.zip
conf/distro: Add removal of btrfs-tools from util-linux ptest depends
btrfs-tools has changed to LGPL-3.1 so to allow util-linux to build, remove the dependency from its ptest package. This may regress some ptests but keeps the gplv2 layer working. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--conf/distro/include/disable-gplv3.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/conf/distro/include/disable-gplv3.inc b/conf/distro/include/disable-gplv3.inc
index bded378..3285543 100644
--- a/conf/distro/include/disable-gplv3.inc
+++ b/conf/distro/include/disable-gplv3.inc
@@ -1,3 +1,4 @@
INCOMPATIBLE_LICENSE = '*GPLv3*'
WARN_QA_remove = 'incompatible-license'
RDEPENDS_${PN}-ptest_remove_pn-glib-2.0 = "python3-dbusmock"
+RDEPENDS_${PN}-ptest_remove_pn-util-linux = "btrfs-tools"