aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa_9.1.3.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_9.1.3.bbappend b/recipes-graphics/mesa/mesa_9.1.3.bbappend
index 9308952..4b3b10b 100644
--- a/recipes-graphics/mesa/mesa_9.1.3.bbappend
+++ b/recipes-graphics/mesa/mesa_9.1.3.bbappend
@@ -23,7 +23,9 @@ python __anonymous () {
# Remove itens from provides
provides = d.getVar('PROVIDES', True).split()
- take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl', 'virtual/libgl']
+ take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl']
+ if 'mx6' in cur_soc_families.split(':'):
+ take_out.append('virtual/libgl')
new_provides = []
for i in provides:
if i not in take_out: