summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-mxsboot_2013.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-mxsboot_2013.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-mxsboot_2013.04.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-mxsboot_2013.04.bb b/recipes-bsp/u-boot/u-boot-mxsboot_2013.04.bb
new file mode 100644
index 0000000..b6c271f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-mxsboot_2013.04.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "U-boot bootloader mxsboot tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+
+PV = "v2013.04"
+
+SRCREV = "7e2cfc83e91229e2573a3b51aec9e8c9fd27ed79"
+SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTSTRIP=true CONFIG_MX28=y'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
+ ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
+}
+
+BBCLASSEXTEND = "native nativesdk"