summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb b/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb
new file mode 100644
index 0000000..4e541b1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "U-boot bootloader mxsboot tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+
+PV = "v2013.01"
+
+SRCREV = "d55bd2b60645e3331f7b12f9251c1eeada44b505"
+SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTSTRIP=true CONFIG_MX28=y'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
+ ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
+}
+
+BBCLASSEXTEND = "native nativesdk"