summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2013.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2013.10.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2013.10.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2013.10.bb b/recipes-bsp/u-boot/u-boot-fslc_2013.10.bb
index 158c9ea..f7784dd 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2013.10.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2013.10.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=6bc50ecab884fce80cd3ef3da8852b08"
COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf60)"
-DEPENDS_mxs += "elftosb-native"
+DEPENDS_mxs += "elftosb-native openssl-native"
PROVIDES += "u-boot"
@@ -15,4 +15,11 @@ SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
S = "${WORKDIR}/git"
+# FIXME: Allow linking of 'tools' binaries with native libraries
+# used for generating the boot logo and other tools used
+# during the build process.
+EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
+ HOSTLDFLAGS="-L${STAGING_BASE_LIBDIR_NATIVE} -L${STAGING_LIBDIR_NATIVE}" \
+ HOSTSTRIP=true'
+
PACKAGE_ARCH = "${MACHINE_ARCH}"