summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2013.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2013.10.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2013.10.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2013.10.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2013.10.bb
new file mode 100644
index 0000000..b87a763
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2013.10.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "U-boot bootloader mxsboot tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=6bc50ecab884fce80cd3ef3da8852b08"
+SECTION = "bootloader"
+PROVIDES = "u-boot-mxsboot"
+
+PV = "v2013.10"
+
+SRCREV = "fb18fa95a14ae875ef0a5421cd9fecc00c7c3a4c"
+SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTSTRIP=true CONFIG_MX28=y'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
+ ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
+}
+
+BBCLASSEXTEND = "native nativesdk"