aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch53
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb26
2 files changed, 79 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch
new file mode 100644
index 0000000..64af773
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch
@@ -0,0 +1,53 @@
+From 5b348e7be67957f4be6fcfa4942128c04f6db905 Mon Sep 17 00:00:00 2001
+From: Adrian Alonso <b38018@freescale.com>
+Date: Thu, 4 Aug 2011 14:24:26 -0500
+Subject: [PATCH] xf86-video-imxfb: fix m4 hardcodded paths
+
+* Fix m4 macros lookup location; remove /usr/share/aclocal path
+
+Signed-off-by: Adrian Alonso <b38018@freescale.com>
+---
+ Makefile.am | 2 +-
+ Makefile.in | 2 +-
+ configure.ac | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 6752256..e205657 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,4 +20,4 @@
+
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = src
+-ACLOCAL_AMFLAGS = -I /usr/share/aclocal
++ACLOCAL_AMFLAGS = -I m4
+diff --git a/Makefile.in b/Makefile.in
+index 5c0ba0e..f829db7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -243,7 +243,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = src
+-ACLOCAL_AMFLAGS = -I /usr/share/aclocal
++ACLOCAL_AMFLAGS = -I m4
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
+diff --git a/configure.ac b/configure.ac
+index a1ac73b..0078b86 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -29,7 +29,7 @@ AC_INIT([xf86-video-imx],
+ AC_CONFIG_SRCDIR([Makefile.am])
+ AM_CONFIG_HEADER([config.h])
+ AC_CONFIG_AUX_DIR(.)
+-AC_CONFIG_MACRO_DIR([/usr/share/aclocal])
++AC_CONFIG_MACRO_DIR([m4])
+
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+--
+1.7.4.1
+
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
new file mode 100644
index 0000000..a77e4ab
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
@@ -0,0 +1,26 @@
+# Copyright (C) 2011 Freescale
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "X.Org X server -- Freescale iMx framebuffer driver"
+LICENSE = "MIT-X"
+RDEPENDS = "amd-gpu-x11-bin-mx51"
+DEPENDS = "virtual/xserver-xf86 virtual/libx11 xproto randrproto util-macros amd-gpu-x11-bin-mx51"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f7bdc0c63080175d1667091b864cb12c"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+SRC_URI = "http://opensource.freescale.com/pub/scm/imx/xserver-xorg-video-imx-${PV}.tar.gz \
+ file://xf86-video-imxfb-fix-m4-hardcodded-paths.patch"
+
+FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
+FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
+EXTRA_OECONF_armv7a = " --enable-neon "
+CFLAGS += " -I${STAGING_INCDIR}/xorg "
+
+S = "${WORKDIR}/xserver-xorg-video-imx-${REL}"
+
+do_install_append () {
+ # driver's la files are not packaged
+ rm -f ${D}${libdir}/xorg/modules/drivers/*.la
+}