summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/imx-base.inc1
-rw-r--r--conf/machine/twr-vf65gs10.conf21
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2013.07.bb2
3 files changed, 23 insertions, 1 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index b7d04b1..bd293fd 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -18,6 +18,7 @@ UBOOT_ENTRYPOINT_mx51 = "0x90008000"
UBOOT_ENTRYPOINT_mx53 = "0x70008000"
UBOOT_ENTRYPOINT_mx6 = "0x10008000"
UBOOT_ENTRYPOINT_mx6sl = "0x80008000"
+UBOOT_ENTRYPOINT_vf60 = "0x80008000"
PREFERRED_VERSION_xserver-xorg_mx6 = "2:1.11.4"
diff --git a/conf/machine/twr-vf65gs10.conf b/conf/machine/twr-vf65gs10.conf
new file mode 100644
index 0000000..00fdff4
--- /dev/null
+++ b/conf/machine/twr-vf65gs10.conf
@@ -0,0 +1,21 @@
+#@TYPE: Machine
+#@NAME: Freescale Vybrid TWR-VF65GS10
+#@SOC: vf60
+#@DESCRIPTION: Machine configuration for Freescale Vybrid TWR-VF65GS10
+
+include conf/machine/include/imx-base.inc
+include conf/machine/include/tune-cortexa5.inc
+
+SOC_FAMILY = "vf60"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-timesys"
+PREFERRED_PROVIDER_u-boot = "u-boot-fslc"
+
+UBOOT_MACHINE = "vf610twr_config"
+
+SDCARD_ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext3"
+IMAGE_FSTYPES ?= "tar.bz2 ext3 sdcard"
+
+SERIAL_CONSOLE = "115200 ttyLP1"
+
+MACHINE_FEATURES = "apm usbgadget usbhost vfat alsa touchscreen"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb
index 3098fdb..5845569 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2013.07.bb
@@ -2,7 +2,7 @@ require recipes-bsp/u-boot/u-boot.inc
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6)"
+COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf60)"
DEPENDS_mxs += "elftosb-native"