aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch53
-rw-r--r--recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch39
-rw-r--r--recipes-extended/dpdk/dpdk_19.11-20.12.bb (renamed from recipes-extended/dpdk/dpdk_19.11-20.04.bb)4
3 files changed, 1 insertions, 95 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch b/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch
deleted file mode 100644
index 3b5a2b3a..00000000
--- a/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 6fe3e96ab6e92f8faca9784a46bc33d92790c2b8 Mon Sep 17 00:00:00 2001
-From: Kevin Traynor <ktraynor@redhat.com>
-Date: Wed, 11 Mar 2020 11:33:00 +0000
-Subject: [PATCH] examples/ipsec-gw: fix gcc 10 maybe-uninitialized warning
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-gcc 10.0.1 reports:
-
-../examples/ipsec-secgw/ipsec_process.c: In function ‘ipsec_process’:
-../examples/ipsec-secgw/ipsec_process.c:132:34:
-error: ‘grp.m’ may be used uninitialized in this function
- [-Werror=maybe-uninitialized]
- 132 | grp[n].cnt = pkts + i - grp[n].m;
- | ~~~~~~^~
-
-This is a correct warning for the initial execution of the statement.
-However, it is the design of the loop that grp[0].cnt will later be
-written with the correct value using an initialized grp[0].m before it
-is used.
-
-In order to remove the warning, initialize grp[0].m for the initial and
-unused calculation of grp[0].cnt.
-
-Fixes: 3e5f4625dc17 ("examples/ipsec-secgw: make data-path to use IPsec library")
-Cc: stable@dpdk.org
-
-Upstream-Status: Backport
-
-Suggested-by: Konstantin Ananyev <konstantin.ananyev@intel.com>
-Signed-off-by: Kevin Traynor <ktraynor@redhat.com>
-Acked-by: Konstantin Ananyev <konstantin.ananyev@intel.com>
-Signed-off-by: Jens Rehsack <jens.rehsack.ext@safrangroup.com>
----
- examples/ipsec-secgw/ipsec_process.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/examples/ipsec-secgw/ipsec_process.c b/examples/ipsec-secgw/ipsec_process.c
-index 2eb5c8b34..37f406d46 100644
---- a/examples/ipsec-secgw/ipsec_process.c
-+++ b/examples/ipsec-secgw/ipsec_process.c
-@@ -125,6 +125,7 @@ sa_group(void *sa_ptr[], struct rte_mbuf *pkts[],
- void * const nosa = &spi;
-
- sa = nosa;
-+ grp[0].m = pkts;
- for (i = 0, n = 0; i != num; i++) {
-
- if (sa != sa_ptr[i]) {
---
-2.17.1
-
diff --git a/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch b/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch
deleted file mode 100644
index 61467377..00000000
--- a/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From aa97b9162b68780ca912a226b5045a3ddab41d3c Mon Sep 17 00:00:00 2001
-From: Chunrong Guo <chunrong.guo@nxp.com>
-Date: Thu, 4 Jul 2019 08:03:56 +0200
-Subject: [PATCH] update WERROR_FLAGS
-
-Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
----
- kernel/linux/kni/Makefile | 2 +-
- mk/toolchain/gcc/rte.vars.mk | 1 +
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile
-index 595bac261..a17939996 100644
---- a/kernel/linux/kni/Makefile
-+++ b/kernel/linux/kni/Makefile
-@@ -14,7 +14,7 @@ MODULE = rte_kni
- MODULE_CFLAGS += -I$(SRCDIR) --param max-inline-insns-single=50
- MODULE_CFLAGS += -I$(RTE_OUTPUT)/include
- MODULE_CFLAGS += -include $(RTE_OUTPUT)/include/rte_config.h
--MODULE_CFLAGS += -Wall -Werror
-+MODULE_CFLAGS += -Wall -Werror -Wno-missing-attributes
-
- -include /etc/lsb-release
-
-diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
-index de5e0d24d..ca2cb5fcd 100644
---- a/mk/toolchain/gcc/rte.vars.mk
-+++ b/mk/toolchain/gcc/rte.vars.mk
-@@ -49,6 +49,7 @@ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
- WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
- WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated
- WERROR_FLAGS += -Wno-error=pedantic
-+WERROR_FLAGS += -Wno-address-of-packed-member
-
- ifeq ($(RTE_DEVEL_BUILD),y)
- WERROR_FLAGS += -Werror
---
-2.17.1
-
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.04.bb b/recipes-extended/dpdk/dpdk_19.11-20.12.bb
index 53ee5095..426713c2 100644
--- a/recipes-extended/dpdk/dpdk_19.11-20.04.bb
+++ b/recipes-extended/dpdk/dpdk_19.11-20.12.bb
@@ -7,11 +7,9 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobr
file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
file://0001-add-Wno-cast-function-type.patch \
file://0001-Add-RTE_KERNELDIR_OUT.patch \
- file://0004-update-WERROR_FLAGS.patch \
- file://0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch \
file://0005-use-python3-instead-of-python.patch \
"
-SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540"
+SRCREV = "7071c27f6f5aefb57de1cffab3484707b1e82e2b"
include dpdk.inc