aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/crconf/crconf_git.bb2
-rw-r--r--recipes-extended/dpdk/dpdk.inc30
-rw-r--r--recipes-extended/dpdk/dpdk_19.11-20.12.bb2
-rw-r--r--recipes-extended/ipc-ust/ipc-ust_git.bb10
-rw-r--r--recipes-extended/jailhouse/jailhouse_0.12.bb16
-rw-r--r--recipes-extended/libpkcs11/libpkcs11_git.bb4
-rw-r--r--recipes-extended/merge-files/merge-files_1.0.bb6
-rw-r--r--recipes-extended/odp/odp-counters_git.bb2
-rw-r--r--recipes-extended/odp/odp-module_git.bb4
-rw-r--r--recipes-extended/odp/odp.inc2
-rw-r--r--recipes-extended/odp/odp_git.bb26
-rw-r--r--recipes-extended/ofp/ofp_git.bb4
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb4
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb2
-rw-r--r--recipes-extended/procps/procps_%.bbappend2
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc6
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb12
-rw-r--r--recipes-extended/testfloat/testfloat_2a.bb4
-rw-r--r--recipes-extended/tsntool/tsntool_git.bb6
19 files changed, 72 insertions, 72 deletions
diff --git a/recipes-extended/crconf/crconf_git.bb b/recipes-extended/crconf/crconf_git.bb
index f8f88d20..1727888a 100644
--- a/recipes-extended/crconf/crconf_git.bb
+++ b/recipes-extended/crconf/crconf_git.bb
@@ -14,4 +14,4 @@ do_install () {
oe_runmake install DESTDIR=${D}
}
-FILES_${PN} += "/share/man/* ${libdir}/* ${sbindir}/*"
+FILES:${PN} += "/share/man/* ${libdir}/* ${sbindir}/*"
diff --git a/recipes-extended/dpdk/dpdk.inc b/recipes-extended/dpdk/dpdk.inc
index 61c02ae7..f4c932ea 100644
--- a/recipes-extended/dpdk/dpdk.inc
+++ b/recipes-extended/dpdk/dpdk.inc
@@ -1,25 +1,25 @@
DESCRIPTION = "Data Plane Development Kit"
HOMEPAGE = "http://dpdk.org"
-RDEPENDS_${PN} += "python3-core"
+RDEPENDS:${PN} += "python3-core"
DEPENDS = "virtual/kernel openssl"
-DEPENDS_append_x86-64 = " numactl"
+DEPENDS:append:x86-64 = " numactl"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
inherit module
COMPATIBLE_HOST = '(aarch64|arm|i.86|x86_64).*-linux'
-COMPATIBLE_HOST_libc-musl = 'null'
-COMPATIBLE_HOST_armv4 = 'null'
-COMPATIBLE_HOST_armv5 = 'null'
-COMPATIBLE_HOST_armv6 = 'null'
+COMPATIBLE_HOST:libc-musl = 'null'
+COMPATIBLE_HOST:armv4 = 'null'
+COMPATIBLE_HOST:armv5 = 'null'
+COMPATIBLE_HOST:armv6 = 'null'
COMPATIBLE_MACHINE = "(imx|qoriq)"
-DPDK_RTE_TARGET_x86-64 = "x86_64-native-linuxapp-gcc"
-DPDK_RTE_TARGET_x86 = "i686-native-linuxapp-gcc"
-DPDK_RTE_TARGET_armv7a = "${ARCH}-armv7a-linuxapp-gcc"
-DPDK_RTE_TARGET_armv7ve = "${ARCH}-armv7a-linuxapp-gcc"
+DPDK_RTE_TARGET:x86-64 = "x86_64-native-linuxapp-gcc"
+DPDK_RTE_TARGET:x86 = "i686-native-linuxapp-gcc"
+DPDK_RTE_TARGET:armv7a = "${ARCH}-armv7a-linuxapp-gcc"
+DPDK_RTE_TARGET:armv7ve = "${ARCH}-armv7a-linuxapp-gcc"
DPDK_RTE_TARGET ?= "${ARCH}-dpaa-linuxapp-gcc"
export RTE_TARGET = "${DPDK_RTE_TARGET}"
@@ -93,13 +93,13 @@ do_install () {
PACKAGES += "${PN}-examples"
-FILES_${PN}-dbg += " \
+FILES:${PN}-dbg += " \
${datadir}/dpdk/.debug \
${datadir}/dpdk/examples/*/.debug \
"
-FILES_${PN}-staticdev += "${datadir}/dpdk/cmdif/lib/*.a \
+FILES:${PN}-staticdev += "${datadir}/dpdk/cmdif/lib/*.a \
"
-FILES_${PN}-dev += " \
+FILES:${PN}-dev += " \
${datadir}/dpdk/${RTE_TARGET}/.config \
${includedir} \
${includedir}/exec-env \
@@ -109,11 +109,11 @@ FILES_${PN}-dev += " \
${datadir}/dpdk/mk \
"
-FILES_${PN} += " ${datadir}/ \
+FILES:${PN} += " ${datadir}/ \
${prefix}/sbin/ \
${prefix}/bin/ \
${libdir}/ \
"
-FILES_${PN}-examples += " \
+FILES:${PN}-examples += " \
${datadir}/examples/* \
"
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.12.bb b/recipes-extended/dpdk/dpdk_19.11-20.12.bb
index 426713c2..37582124 100644
--- a/recipes-extended/dpdk/dpdk_19.11-20.12.bb
+++ b/recipes-extended/dpdk/dpdk_19.11-20.12.bb
@@ -13,7 +13,7 @@ SRCREV = "7071c27f6f5aefb57de1cffab3484707b1e82e2b"
include dpdk.inc
-do_install_append () {
+do_install:append () {
# Remove the unneeded dir
rm -rf ${D}/${datadir}/${RTE_TARGET}/app
}
diff --git a/recipes-extended/ipc-ust/ipc-ust_git.bb b/recipes-extended/ipc-ust/ipc-ust_git.bb
index df496c28..f307816e 100644
--- a/recipes-extended/ipc-ust/ipc-ust_git.bb
+++ b/recipes-extended/ipc-ust/ipc-ust_git.bb
@@ -40,12 +40,12 @@ do_install () {
install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib
}
-FILES_${PN} += "${base_libdir}/*.so /ipc/*"
-FILES_${PN}-dev = "${includedir}"
-FILES_${PN}-dbg += "/ipc/.debug"
+FILES:${PN} += "${base_libdir}/*.so /ipc/*"
+FILES:${PN}-dev = "${includedir}"
+FILES:${PN}-dbg += "/ipc/.debug"
-INSANE_SKIP_${PN} += "file-rdeps"
-INSANE_SKIP_${PN}-dev += "dev-elf"
+INSANE_SKIP:${PN} += "file-rdeps"
+INSANE_SKIP:${PN}-dev += "dev-elf"
COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-extended/jailhouse/jailhouse_0.12.bb b/recipes-extended/jailhouse/jailhouse_0.12.bb
index c49d7f5b..43b4cdf5 100644
--- a/recipes-extended/jailhouse/jailhouse_0.12.bb
+++ b/recipes-extended/jailhouse/jailhouse_0.12.bb
@@ -39,9 +39,9 @@ CELLCONF_DIR ?= "${JH_DATADIR}/configs"
INMATES_DIR ?= "${JH_DATADIR}/inmates"
JH_CONFIG ?= "${S}/ci/jailhouse-config-x86.h"
-JH_CONFIG_x86 ?= "${S}/ci/jailhouse-config-x86.h"
-JH_CONFIG_x86-64 ?= "${S}/ci/jailhouse-config-x86.h"
-JH_CONFIG_arm ?= "${S}/ci/jailhouse-config-banana-pi.h"
+JH_CONFIG:x86 ?= "${S}/ci/jailhouse-config-x86.h"
+JH_CONFIG:x86-64 ?= "${S}/ci/jailhouse-config-x86.h"
+JH_CONFIG:arm ?= "${S}/ci/jailhouse-config-banana-pi.h"
do_configure() {
if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ];
@@ -101,22 +101,22 @@ do_install() {
PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse"
-FILES_${PN} += "${nonarch_base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
-FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}/pyjailhouse"
+FILES:${PN} += "${nonarch_base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
+FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}/pyjailhouse"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3-curses \
python3-datetime \
python3-mmap \
"
-RDEPENDS_pyjailhouse = " \
+RDEPENDS:pyjailhouse = " \
python3-core \
python3-ctypes \
python3-fcntl \
python3-shell \
"
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
COMPATIBLE_MACHINE = "(mx8m)"
diff --git a/recipes-extended/libpkcs11/libpkcs11_git.bb b/recipes-extended/libpkcs11/libpkcs11_git.bb
index 30f33a20..5496b09c 100644
--- a/recipes-extended/libpkcs11/libpkcs11_git.bb
+++ b/recipes-extended/libpkcs11/libpkcs11_git.bb
@@ -34,6 +34,6 @@ do_install(){
}
PARALLEL_MAKE = ""
-INSANE_SKIP_${PN} = "ldflags dev-deps"
-INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
+INSANE_SKIP:${PN} = "ldflags dev-deps"
+INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/merge-files/merge-files_1.0.bb b/recipes-extended/merge-files/merge-files_1.0.bb
index 6fe5b637..5b3ca7ed 100644
--- a/recipes-extended/merge-files/merge-files_1.0.bb
+++ b/recipes-extended/merge-files/merge-files_1.0.bb
@@ -17,6 +17,6 @@ do_install () {
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-FILES_${PN} = "/*"
-ALLOW_EMPTY_${PN} = "1"
-INSANE_SKIP_${PN} = "debug-files dev-so"
+FILES:${PN} = "/*"
+ALLOW_EMPTY:${PN} = "1"
+INSANE_SKIP:${PN} = "debug-files dev-so"
diff --git a/recipes-extended/odp/odp-counters_git.bb b/recipes-extended/odp/odp-counters_git.bb
index 860dd5fa..9d88ea43 100644
--- a/recipes-extended/odp/odp-counters_git.bb
+++ b/recipes-extended/odp/odp-counters_git.bb
@@ -2,7 +2,7 @@ require odp.inc
inherit module
-do_compile_prepend () {
+do_compile:prepend () {
export KERNEL_PATH="${STAGING_KERNEL_DIR}"
export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}"
cd ${S}/test/debug/perf_counters
diff --git a/recipes-extended/odp/odp-module_git.bb b/recipes-extended/odp/odp-module_git.bb
index 46b89654..0748e5bf 100644
--- a/recipes-extended/odp/odp-module_git.bb
+++ b/recipes-extended/odp/odp-module_git.bb
@@ -2,7 +2,7 @@ require odp.inc
inherit module
-do_compile_prepend () {
+do_compile:prepend () {
export KERNEL_PATH="${STAGING_KERNEL_DIR}"
export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}"
cd ${S}/kern
@@ -13,4 +13,4 @@ do_install () {
install -m 755 ${S}/kern/odpfsl_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/odp
}
-PKG_${PN} = "kernel-module-${PN}"
+PKG:${PN} = "kernel-module-${PN}"
diff --git a/recipes-extended/odp/odp.inc b/recipes-extended/odp/odp.inc
index 129f77ae..d1e10b0f 100644
--- a/recipes-extended/odp/odp.inc
+++ b/recipes-extended/odp/odp.inc
@@ -6,7 +6,7 @@ SECTION = "console/network"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ca6103dc75397fb6bec596187d6b7829"
-FILESEXTRAPATHS_prepend := "${THISDIR}/odp:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/odp:"
SRC_URI = " \
git://source.codeaurora.org/external/qoriq/qoriq-components/odp;nobranch=1 \
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb
index 00575e24..9c94e432 100644
--- a/recipes-extended/odp/odp_git.bb
+++ b/recipes-extended/odp/odp_git.bb
@@ -6,17 +6,17 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
DEPENDS = "openssl cunit libxml2"
-RDEPENDS_${PN} = "bash libcrypto libssl odp-module odp-counters"
+RDEPENDS:${PN} = "bash libcrypto libssl odp-module odp-counters"
ODP_SOC ?= ""
-ODP_SOC_ls1043ardb = "LS1043"
-ODP_SOC_ls1046ardb = "LS1046"
+ODP_SOC:ls1043ardb = "LS1043"
+ODP_SOC:ls1046ardb = "LS1046"
ODP_PLATFORM ?= "linux-dpaa2"
ODP_BUILD_TYPE ?= "ls2088"
-ODP_BUILD_TYPE_ls1043ardb = "ls1043"
-ODP_BUILD_TYPE_ls1046ardb = "ls1046"
-ODP_BUILD_TYPE_ls2080ardb = "ls2080"
-ODP_BUILD_TYPE_ls1088ardb = "ls1088"
+ODP_BUILD_TYPE:ls1043ardb = "ls1043"
+ODP_BUILD_TYPE:ls1046ardb = "ls1046"
+ODP_BUILD_TYPE:ls2080ardb = "ls2080"
+ODP_BUILD_TYPE:ls1088ardb = "ls1088"
EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \
--enable-test-vald \
@@ -34,17 +34,17 @@ CFLAGS += "-Wno-format-truncation -Wno-maybe-uninitialized -Wno-implicit-fallthr
PACKAGECONFIG[perf] = "--enable-test-perf,,,"
-do_configure_prepend () {
+do_configure:prepend () {
export SOC=${ODP_SOC}
${S}/bootstrap
}
-do_compile_prepend () {
+do_compile:prepend () {
export SOC=${ODP_SOC}
export ARCH=${TUNE_ARCH}
}
-do_install_append () {
+do_install:append () {
install -d ${D}${includedir}/odp/kni
install -d ${D}${includedir}/odp/kern
install -d ${D}${includedir}/odp/flib/mc
@@ -58,6 +58,6 @@ do_install_append () {
sed -i -e 's#platform/linux-dpaa2/##g' ${D}${includedir}/odp/kern/*.h
}
-FILES_${PN}-staticdev += "${datadir}/opendataplane/*.la"
-FILES_${PN} += "/usr/odp/bin /usr/odp/scripts /usr/odp/debug /usr/odp/test/validation /usr/odp/test/performance /usr/odp/test/miscellaneous /usr/odp/test/api_test"
-FILES_${PN}-dbg += "/usr/odp/bin/.debug /usr/odp/debug/.debug /usr/odp/test/validation/.debug /usr/odp/test/performance/.debug /usr/odp/test/miscellaneous/.debug /usr/odp/test/api_test/.debug"
+FILES:${PN}-staticdev += "${datadir}/opendataplane/*.la"
+FILES:${PN} += "/usr/odp/bin /usr/odp/scripts /usr/odp/debug /usr/odp/test/validation /usr/odp/test/performance /usr/odp/test/miscellaneous /usr/odp/test/api_test"
+FILES:${PN}-dbg += "/usr/odp/bin/.debug /usr/odp/debug/.debug /usr/odp/test/validation/.debug /usr/odp/test/performance/.debug /usr/odp/test/miscellaneous/.debug /usr/odp/test/api_test/.debug"
diff --git a/recipes-extended/ofp/ofp_git.bb b/recipes-extended/ofp/ofp_git.bb
index c76eafd7..ec7328c8 100644
--- a/recipes-extended/ofp/ofp_git.bb
+++ b/recipes-extended/ofp/ofp_git.bb
@@ -32,6 +32,6 @@ do_configure () {
${S}/configure ${EXTRA_OECONF}
}
-FILES_${PN} += "/usr/ofp/bin"
-FILES_${PN}-dbg += "/usr/ofp/bin/.debug"
+FILES:${PN} += "/usr/ofp/bin"
+FILES:${PN}-dbg += "/usr/ofp/bin/.debug"
COMPATIBLE_MACHINE = "(ls2088a|ls1088a)"
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
index 9e817579..f9d32773 100644
--- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
@@ -3,7 +3,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
DEPENDS = "dpdk python3-six-native coreutils-native"
-RDEPENDS_${PN} = "bash libcrypto libssl python3"
+RDEPENDS:${PN} = "bash libcrypto libssl python3"
inherit python3native
@@ -42,7 +42,7 @@ do_install() {
chmod 777 -R ${D}${bindir}/ovs-dpdk/*
}
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
INHIBIT_PACKAGE_STRIP = "1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
index f3a73c35..6a039129 100644
--- a/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
+++ b/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
@@ -26,7 +26,7 @@ do_install() {
cp -f ${S}/Pktgen.lua ${D}${bindir}/
}
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
INHIBIT_PACKAGE_STRIP = "1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
PARALLEL_MAKE = ""
diff --git a/recipes-extended/procps/procps_%.bbappend b/recipes-extended/procps/procps_%.bbappend
index face0ccc..43fb349b 100644
--- a/recipes-extended/procps/procps_%.bbappend
+++ b/recipes-extended/procps/procps_%.bbappend
@@ -1,4 +1,4 @@
-do_install_append_qoriq-ppc() {
+do_install:append:qoriq-ppc() {
for keyword in \
net.ipv4.conf.default.rp_filter \
net.ipv4.conf.all.rp_filter \
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 8a62d9cb..55f20ed5 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Secure Object"
LICENSE = "BSD"
DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
-RDEPENDS_${PN} = "bash libcrypto libssl"
+RDEPENDS:${PN} = "bash libcrypto libssl"
DEPENDS += "python3-pycryptodomex-native"
@@ -20,9 +20,9 @@ export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
INHIBIT_PACKAGE_STRIP = "1"
PARALLEL_MAKE = ""
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
COMPATIBLE_MACHINE = "(qoriq-arm64)"
DEBUG_BUILD = "1"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 2d723738..1fd1fea3 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -4,15 +4,15 @@ LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2"
S = "${WORKDIR}/git"
-RDEPENDS_{PN} += "secure-obj-module"
+RDEPENDS:{PN} += "secure-obj-module"
WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
-ARCH_qoriq-arm64 = "aarch64"
-ARCH_qoriq-arm = "arm"
+ARCH:qoriq-arm64 = "aarch64"
+ARCH:qoriq-arm = "arm"
do_compile() {
unset LDFLAGS
@@ -41,6 +41,6 @@ do_install() {
rm -rf ${D}${bindir}/test
}
-FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
-INSANE_SKIP_${PN} = "dev-deps ldflags"
-INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
+FILES:${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
+INSANE_SKIP:${PN} = "dev-deps ldflags"
+INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
diff --git a/recipes-extended/testfloat/testfloat_2a.bb b/recipes-extended/testfloat/testfloat_2a.bb
index 800cef3d..4ed2ceb3 100644
--- a/recipes-extended/testfloat/testfloat_2a.bb
+++ b/recipes-extended/testfloat/testfloat_2a.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://testfloat/testfloat.txt;beginline=87;endline=95;md5=b
SRC_URI = " http://www.jhauser.us/arithmetic/TestFloat-2a.tar.Z;name=TestFloat \
http://www.jhauser.us/arithmetic/SoftFloat-2b.tar.Z;name=SoftFloat \
"
-SRC_URI_append_qoriq-ppc = " file://SoftFloat-powerpc-1.patch \
+SRC_URI:append:qoriq-ppc = " file://SoftFloat-powerpc-1.patch \
file://TestFloat-powerpc-E500v2-SPE-1.patch \
file://Yocto-replace-COMPILE_PREFIX-gcc.patch \
"
@@ -40,6 +40,6 @@ do_install(){
install testfloat/powerpc-linux-gcc/testsoftfloat ${D}/${bindir}
}
-COMPATIBLE_HOST_e500v2 = ".*"
+COMPATIBLE_HOST:e500v2 = ".*"
COMPATIBLE_HOST ?= "(none)"
diff --git a/recipes-extended/tsntool/tsntool_git.bb b/recipes-extended/tsntool/tsntool_git.bb
index 8ef79d27..f4f10938 100644
--- a/recipes-extended/tsntool/tsntool_git.bb
+++ b/recipes-extended/tsntool/tsntool_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
-do_compile_prepend() {
+do_compile:prepend() {
mkdir -p ${S}/include/linux
cp -r ${STAGING_KERNEL_DIR}/include/uapi/linux/tsn.h ${S}/include/linux
}
@@ -25,7 +25,7 @@ do_install() {
}
PACKAGES = "${PN}-dbg ${PN}"
-FILES_${PN} = "${libdir}/libtsn.so ${bindir}/*"
-INSANE_SKIP_${PN} += "file-rdeps rpaths dev-so"
+FILES:${PN} = "${libdir}/libtsn.so ${bindir}/*"
+INSANE_SKIP:${PN} += "file-rdeps rpaths dev-so"
COMPATIBLE_MACHINE = "(qoriq)"
PARALLEL_MAKE = ""