aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/secure-obj/secure-obj_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/secure-obj/secure-obj_git.bb')
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 2d723738..1fd1fea3 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -4,15 +4,15 @@ LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2"
S = "${WORKDIR}/git"
-RDEPENDS_{PN} += "secure-obj-module"
+RDEPENDS:{PN} += "secure-obj-module"
WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
-ARCH_qoriq-arm64 = "aarch64"
-ARCH_qoriq-arm = "arm"
+ARCH:qoriq-arm64 = "aarch64"
+ARCH:qoriq-arm = "arm"
do_compile() {
unset LDFLAGS
@@ -41,6 +41,6 @@ do_install() {
rm -rf ${D}${bindir}/test
}
-FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
-INSANE_SKIP_${PN} = "dev-deps ldflags"
-INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
+FILES:${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
+INSANE_SKIP:${PN} = "dev-deps ldflags"
+INSANE_SKIP:${PN}-dev = "ldflags dev-elf"