aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/cst/cst_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/cst/cst_git.bb')
-rw-r--r--recipes-extended/cst/cst_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-extended/cst/cst_git.bb b/recipes-extended/cst/cst_git.bb
new file mode 100644
index 00000000..729ee5f8
--- /dev/null
+++ b/recipes-extended/cst/cst_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "utility for security boot"
+SECTION = "cst"
+LICENSE = "BSD"
+
+# TODO: fix license - this file is not a license
+LIC_FILES_CHKSUM = "file://RELEASENOTES;beginline=8;endline=43;md5=5a7b22a2c96b5f94e0498c5f413aa8d3"
+
+DEPENDS += "openssl"
+
+inherit kernel-arch
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;branch=master"
+SRCREV = "6f57c86c93cab0f4d0a40d83b685afa6932a6301"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
+
+PARALLEL_MAKE = ""
+
+do_install () {
+ oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
+}
+
+FILES_${PN}-dbg += "${bindir}/cst/.debug"
+BBCLASSEXTEND = "native nativesdk"