aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/boot-format/boot-format/flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/boot-format/boot-format/flags.patch')
-rw-r--r--recipes-bsp/boot-format/boot-format/flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-bsp/boot-format/boot-format/flags.patch b/recipes-bsp/boot-format/boot-format/flags.patch
new file mode 100644
index 00000000..cddb34cd
--- /dev/null
+++ b/recipes-bsp/boot-format/boot-format/flags.patch
@@ -0,0 +1,21 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -3,14 +3,14 @@
+ INSTALL=install
+ PREFIX=/usr
+
+-CFLAGS=-Wall
++override CFLAGS+=-Wall
+
+ all: boot_format
+
+ boot_format.o: boot_format.c boot_format.h
+
+ boot_format: boot_format.o
+- $(CC) $< -o $@
++ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
+
+ install: boot_format
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin