aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb b/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb
deleted file mode 100644
index 57f305a6..00000000
--- a/meta-fsl-ppc/recipes-bsp/rcw/rcw_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "Reset Configuration Word"
-DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
-LICENSE = "BSD"
-PR = "r8"
-
-LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
-
-inherit deploy
-
-SRCBRANCH = "master"
-SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2"
-SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \
- file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \
-"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/"
-
-do_install () {
- oe_runmake install
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/rcw
- cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/
-}
-addtask deploy after do_install
-
-PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
-
-ALLOW_EMPTY_${PN} = "1"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(qoriq-ppc)"