aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/uuu_bootloader_tag.bbclass11
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8.14.inc (renamed from recipes-bsp/firmware-imx/firmware-imx-8.13.inc)6
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8_8.14.bb (renamed from recipes-bsp/firmware-imx/firmware-imx-8_8.13.bb)0
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8m_8.14.bb (renamed from recipes-bsp/firmware-imx/firmware-imx-8m_8.13.bb)0
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx_8.14.bb (renamed from recipes-bsp/firmware-imx/firmware-imx_8.13.bb)15
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb2
-rw-r--r--recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch135
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb10
-rw-r--r--recipes-bsp/imx-mkimage/imx-mkimage_git.inc4
-rw-r--r--recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.11.0.bb (renamed from recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.10.0.bb)6
-rw-r--r--recipes-bsp/imx-seco/imx-seco-libs_git.bb6
-rw-r--r--recipes-bsp/imx-seco/imx-seco_3.8.4.bb (renamed from recipes-bsp/imx-seco/imx-seco_3.8.2.bb)6
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb4
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.6.0.bb (renamed from recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb)6
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.1.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb)4
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.24.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb)6
-rw-r--r--recipes-bsp/isp-imx/basler-camera_4.2.2.16.0.bb (renamed from recipes-bsp/isp-imx/basler-camera_4.2.2.15.0.bb)6
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.16.0.bb (renamed from recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb)7
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc6
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb9
21 files changed, 84 insertions, 169 deletions
diff --git a/classes/uuu_bootloader_tag.bbclass b/classes/uuu_bootloader_tag.bbclass
new file mode 100644
index 00000000..fb6acd72
--- /dev/null
+++ b/classes/uuu_bootloader_tag.bbclass
@@ -0,0 +1,11 @@
+# Append a tag to the bootloader image used in the SD card image. The tag
+# contains the size of the bootloader image so UUU can easily find the end of
+# the bootloader in the SD card image.
+do_deploy:append() {
+ if [ "${UUU_BOOTLOADER}" != "" ]; then
+ cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED}
+ ln -sf ${UUU_BOOTLOADER_TAGGED} ${DEPLOYDIR}/${UUU_BOOTLOADER}
+ stat -L -cUUUBURNXXOEUZX7+A-XY5601QQWWZ%sEND ${DEPLOYDIR}/${UUU_BOOTLOADER} \
+ >> ${DEPLOYDIR}/${UUU_BOOTLOADER}
+ fi
+}
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8.13.inc b/recipes-bsp/firmware-imx/firmware-imx-8.14.inc
index ff739c4c..5af24283 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8.13.inc
+++ b/recipes-bsp/firmware-imx/firmware-imx-8.14.inc
@@ -3,14 +3,14 @@
# Copyright (C) 2018 O.S. Systems Software LTDA.
SECTION = "base"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
SRC_URI = " \
${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true \
"
-SRC_URI[md5sum] = "97eb12ba899bc29a5375993889708bfb"
-SRC_URI[sha256sum] = "8b7aa9b41a0389e5f40bdf91cb1224f79ea4c2e7fc36292f27ad4bef7044d7f0"
+SRC_URI[md5sum] = "3357c84e48fdc220984a9642d1e808f6"
+SRC_URI[sha256sum] = "bfe9c57857e8442e7eb26ba3e1020733b09a7c9b83952ad4822980546c58a7f4"
S = "${WORKDIR}/firmware-imx-${PV}"
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8_8.13.bb b/recipes-bsp/firmware-imx/firmware-imx-8_8.14.bb
index 6ea16d5b..6ea16d5b 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8_8.13.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx-8_8.14.bb
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8m_8.13.bb b/recipes-bsp/firmware-imx/firmware-imx-8m_8.14.bb
index a48356ed..a48356ed 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8m_8.13.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx-8m_8.14.bb
diff --git a/recipes-bsp/firmware-imx/firmware-imx_8.13.bb b/recipes-bsp/firmware-imx/firmware-imx_8.14.bb
index 68539a61..5628e40b 100644
--- a/recipes-bsp/firmware-imx/firmware-imx_8.13.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx_8.14.bb
@@ -1,5 +1,5 @@
# Copyright (C) 2012-2016 Freescale Semiconductor
-# Copyright (C) 2017-2020 NXP
+# Copyright (C) 2017-2021 NXP
# Copyright (C) 2018 O.S. Systems Software LTDA.
SUMMARY = "Freescale i.MX firmware"
DESCRIPTION = "Freescale i.MX firmware such as for the VPU"
@@ -43,10 +43,9 @@ do_install() {
# NOTE:
# Only install pre-defined list of firmware files, since the source archive contains
# also HDMI binary files for imx8m derivatives, which are taken care of by another recipe
- install -d ${D}${nonarch_base_libdir}/firmware/imx/hdmi
- install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi
- install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi
- install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi
+ install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${D}${nonarch_base_libdir}/firmware
+ install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${D}${nonarch_base_libdir}/firmware
+ install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${D}${nonarch_base_libdir}/firmware
# VPU Firmware section
# NOTE:
@@ -124,6 +123,10 @@ PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-* ${PN}-easrc-* ${PN}-xcvr-* ${PN}-xu
PACKAGES = "${PN} ${PN}-epdc ${PN}-hdmi"
FILES:${PN}-epdc = "${nonarch_base_libdir}/firmware/imx/epdc/"
-FILES:${PN}-hdmi = "${nonarch_base_libdir}/firmware/imx/hdmi/"
+FILES:${PN}-hdmi = " \
+ ${nonarch_base_libdir}/firmware/hdmitxfw.bin \
+ ${nonarch_base_libdir}/firmware/hdmirxfw.bin \
+ ${nonarch_base_libdir}/firmware/dpfw.bin \
+"
COMPATIBLE_MACHINE = "(imx|use-mainline-bsp)"
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index ce30822e..afb31698 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -10,7 +10,7 @@ PV .= "+git${SRCPV}"
SRCBRANCH = "lf_v2.4"
SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
"
-SRCREV = "bb4957067d4b96a6ee197a333425948e409e990d"
+SRCREV = "5782363f92a2fdf926784449270433cf3ddf44bd"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch b/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
index 3c2842af..5a4a895b 100644
--- a/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
+++ b/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
@@ -1,19 +1,10 @@
-From 9cf936493388897379f33b511ec869c6fa5409ce Mon Sep 17 00:00:00 2001
+From f281b935985f1b592534ee2837ce0d0b28c7dc43 Mon Sep 17 00:00:00 2001
From: Andrey Zhizhikin <andrey.z@gmail.com>
-Date: Thu, 22 Apr 2021 12:20:28 +0000
+Date: Tue, 11 Jan 2022 15:32:05 -0600
Subject: [PATCH] mkimage_fit_atf: fix fit generator node naming
-Since upstream commit 79af75f777 ("fit: Don't allow verification of images
-with @ nodes") [1], unit addresses on the nodes are prohibited and nodes
-that do contain those addresses are ignored during the ITS parsing. This
-is done in an effort to cover the CVE-2021-27138, where nodes with unit
-addresses can be mis-interpreted by libfdt.
-
-Correct FIT generator script and replace nodes with unit addresses to
-plain node names with "-" instead of "@" to create a unique naming.
-
-In addition, extend sections which contains "firmware" in their types
-with "os" parameter to conform to the latest FIT specification.
+Extend sections which contains "firmware" in their types with "os"
+parameter to conform to the latest FIT specification.
Indicate that load and entry addresses are covered by one 32-bit value
by adding "address-cells" in the root node of the generated ITS.
@@ -23,40 +14,13 @@ Link: [1] https://github.com/u-boot/u-boot/commit/79af75f7776fc20b0d7eb6afe1e27c
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Cc: Tom Hochstein <tom.hochstein@nxp.com>
---
- iMX8M/mkimage_fit_atf.sh | 40 ++++++++++++++++++++++------------------
- 1 file changed, 22 insertions(+), 18 deletions(-)
+ iMX8M/mkimage_fit_atf.sh | 4 ++++
+ 1 file changed, 4 insertions(+)
diff --git a/iMX8M/mkimage_fit_atf.sh b/iMX8M/mkimage_fit_atf.sh
-index 95749b1..10903ea 100755
+index 4f2b3f3..10903ea 100755
--- a/iMX8M/mkimage_fit_atf.sh
+++ b/iMX8M/mkimage_fit_atf.sh
-@@ -23,7 +23,7 @@ else
- fi
-
- BL32="tee.bin"
--LOADABLES="\"atf@1\""
-+LOADABLES="\"atf-1\""
-
- if [ ! -f $BL32 ]; then
- BL32=/dev/null
-@@ -31,7 +31,7 @@ else
- echo "Building with TEE support, make sure your bl31 is compiled with spd. If you do not want tee, please delete tee.bin" >&2
- echo "tee.bin size: " >&2
- ls -lct tee.bin | awk '{print $5}' >&2
-- LOADABLES="$LOADABLES, \"tee@1\""
-+ LOADABLES="$LOADABLES, \"tee-1\""
- fi
-
- BL33="u-boot-nodtb.bin"
-@@ -41,7 +41,7 @@ if [ ! -f $DEK_BLOB ]; then
- DEK_BLOB=/dev/null
- else
- echo "Building with encrypted boot support, make sure to replace DEK Blob in final image." >&2
-- LOADABLES="\"dek_blob@1\", $LOADABLES"
-+ LOADABLES="\"dek_blob-1\", $LOADABLES"
- fi
-
- if [ ! -f $BL33 ]; then
@@ -64,10 +64,12 @@ cat << __HEADER_EOF
/ {
@@ -64,103 +28,28 @@ index 95749b1..10903ea 100755
+ #address-cells = <1>;
images {
-- uboot@1 {
-+ uboot-1 {
+ uboot-1 {
description = "U-Boot (64-bit)";
+ os = "u-boot";
data = /incbin/("$BL33");
type = "standalone";
arch = "arm64";
-@@ -80,7 +82,7 @@ cnt=1
- for dtname in $*
- do
- cat << __FDT_IMAGE_EOF
-- fdt@$cnt {
-+ fdt-$cnt {
- description = "$(basename $dtname .dtb)";
- data = /incbin/("$dtname");
- type = "flat_dt";
-@@ -91,8 +93,9 @@ cnt=$((cnt+1))
- done
-
+@@ -93,6 +95,7 @@ done
cat << __HEADER_EOF
-- atf@1 {
-+ atf-1 {
+ atf-1 {
description = "ARM Trusted Firmware";
+ os = "arm-trusted-firmware";
data = /incbin/("$BL31");
type = "firmware";
arch = "arm64";
-@@ -104,8 +107,9 @@ __HEADER_EOF
-
- if [ -f $BL32 ]; then
+@@ -106,6 +109,7 @@ if [ -f $BL32 ]; then
cat << __HEADER_EOF
-- tee@1 {
-+ tee-1 {
+ tee-1 {
description = "TEE firmware";
+ os = "op-tee-firmware";
data = /incbin/("$BL32");
type = "firmware";
arch = "arm64";
-@@ -118,7 +122,7 @@ fi
-
- if [ -f $DEK_BLOB ]; then
- cat << __HEADER_EOF
-- dek_blob@1 {
-+ dek_blob-1 {
- description = "dek_blob";
- data = /incbin/("$DEK_BLOB");
- type = "script";
-@@ -131,7 +135,7 @@ fi
- cat << __CONF_HEADER_EOF
- };
- configurations {
-- default = "config@1";
-+ default = "config-1";
-
- __CONF_HEADER_EOF
-
-@@ -141,31 +145,31 @@ do
- if [ -f $BL32 ]; then
- if [ $ROLLBACK_INDEX_IN_FIT ]; then
- cat << __CONF_SECTION_EOF
-- config@$cnt {
-+ config-$cnt {
- description = "$(basename $dtname .dtb)";
-- firmware = "uboot@1";
-+ firmware = "uboot-1";
- loadables = $LOADABLES;
-- fdt = "fdt@$cnt";
-+ fdt = "fdt-$cnt";
- rbindex = "$ROLLBACK_INDEX_IN_FIT";
- };
- __CONF_SECTION_EOF
- else
- cat << __CONF_SECTION_EOF
-- config@$cnt {
-+ config-$cnt {
- description = "$(basename $dtname .dtb)";
-- firmware = "uboot@1";
-+ firmware = "uboot-1";
- loadables = $LOADABLES;
-- fdt = "fdt@$cnt";
-+ fdt = "fdt-$cnt";
- };
- __CONF_SECTION_EOF
- fi
- else
- cat << __CONF_SECTION1_EOF
-- config@$cnt {
-+ config-$cnt {
- description = "$(basename $dtname .dtb)";
-- firmware = "uboot@1";
-+ firmware = "uboot-1";
- loadables = $LOADABLES;
-- fdt = "fdt@$cnt";
-+ fdt = "fdt-$cnt";
- };
- __CONF_SECTION1_EOF
- fi
--
2.17.1
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index f8ebb730..b332e079 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -24,7 +24,10 @@ DEPENDS:append:mx8m = " u-boot-mkimage-native dtc-native"
BOOT_NAME = "imx-boot"
PROVIDES = "${BOOT_NAME}"
-inherit deploy
+inherit deploy uuu_bootloader_tag
+
+UUU_BOOTLOADER = "${BOOT_NAME}"
+UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged"
# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build
CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}"
@@ -190,9 +193,8 @@ do_deploy() {
fi
install -m 0644 ${S}/${BOOT_CONFIG_MACHINE}-${target} ${DEPLOYDIR}
done
- cd ${DEPLOYDIR}
- ln -sf ${BOOT_CONFIG_MACHINE}-${IMAGE_IMXBOOT_TARGET} ${BOOT_NAME}
- cd -
+
+ ln -sf ${BOOT_CONFIG_MACHINE}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/${BOOT_NAME}
}
addtask deploy before do_build after do_compile
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc
index c51c1e08..b4d32a54 100644
--- a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc
+++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc
@@ -2,12 +2,12 @@
DEPENDS = "zlib-native openssl-native"
-SRCBRANCH = "lf-5.10.52_2.1.0"
+SRCBRANCH = "lf-5.10.72_2.2.0"
SRC_URI = "git://source.codeaurora.org/external/imx/imx-mkimage.git;protocol=https;branch=${SRCBRANCH} \
file://0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch \
file://0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch \
"
-SRCREV = "1112c88470f339dc631e2a7117087f416af6d6b5"
+SRCREV = "7a277c8a1a21ff921d217889dde6a9f84e6d2168"
S = "${WORKDIR}/git"
BOOT_TOOLS = "imx-boot-tools"
diff --git a/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.10.0.bb b/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.11.0.bb
index e3dad7da..27f7a2a7 100644
--- a/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.10.0.bb
+++ b/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.11.0.bb
@@ -3,15 +3,15 @@
DESCRIPTION = "i.MX System Controller Firmware"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
SECTION = "BSP"
inherit fsl-eula-unpack pkgconfig deploy
SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
-SRC_URI[md5sum] = "5c2b9d35e526136042a84e8d8f6c116e"
-SRC_URI[sha256sum] = "0adc3d2c2df250a873232f1b62b14674694b50a4e01dd6ceae479e4ff2b2276b"
+SRC_URI[md5sum] = "95f1b0a148c323968c0741e807995948"
+SRC_URI[sha256sum] = "4ad2999088098c7d95837b7dc88adceda319c2102c8bdf55bf6e9453653fba00"
BOARD_TYPE ?= "mek"
SC_FIRMWARE_NAME ?= "INVALID"
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
index 41128e28..f8c3c239 100644
--- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb
+++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
@@ -4,14 +4,14 @@ SUMMARY = "NXP i.MX SECO library"
DESCRIPTION = "NXP i.MX Security Controller library"
SECTION = "base"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://EULA.txt;md5=85d06b38f17b935ca11784d67075b846"
+LIC_FILES_CHKSUM = "file://EULA.txt;md5=76871788f27c28af824e2ec1ca187832"
DEPENDS = "zlib"
-SRCBRANCH = "lf-5.10.y_2.0.0"
+SRCBRANCH = "lf-5.10.72_2.2.0"
SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \
file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch"
-SRCREV = "44caf511023012e9eda93f8bf64c90eaff1bade6"
+SRCREV = "3e8ad6b168f23a8c6ecd75edabc18d2673403e24"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-seco/imx-seco_3.8.2.bb b/recipes-bsp/imx-seco/imx-seco_3.8.4.bb
index bd749e4f..bd5739cd 100644
--- a/recipes-bsp/imx-seco/imx-seco_3.8.2.bb
+++ b/recipes-bsp/imx-seco/imx-seco_3.8.4.bb
@@ -4,14 +4,14 @@ SUMMARY = "NXP i.MX SECO firmware"
DESCRIPTION = "NXP i.MX Security Controller firmware"
SECTION = "base"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
inherit fsl-eula-unpack use-imx-security-controller-firmware deploy
SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
-SRC_URI[md5sum] = "92a15f2ffe162374806e2dfe9b0aa2e9"
-SRC_URI[sha256sum] = "c543cd3ec4d30c0cf5ee2a2f4dc7efe209363e45087e0b7c380b727b7bcf2c8a"
+SRC_URI[md5sum] = "38d298cda9ea91db945b266bd6774e07"
+SRC_URI[sha256sum] = "ed65381fac7a17a7594099191952821ed3f3f54c944937926dc19f82ecd8fef5"
do_compile[noexec] = "1"
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index f7ef0348..d33ad18c 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -16,12 +16,12 @@ DEPENDS:append:imxvpu = " virtual/imxvpu"
PE = "1"
PV = "7.0+${SRCPV}"
-SRCBRANCH = "lf-5.10.52_2.1.0"
+SRCBRANCH = "lf-5.10.72_2.2.0"
SRC_URI = " \
git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
file://memtool_profile \
"
-SRCREV = "2dcb987a91183770f328258b424d9ad2fdfdc17a"
+SRCREV = "a26b1ee51177e317aa05251d4c8f10c4c68064f6"
S = "${WORKDIR}/git"
inherit module-base use-imx-headers
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.6.0.bb
index e6cffaca..2a17d76f 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.6.0.bb
@@ -2,7 +2,7 @@
DESCRIPTION = "i.MX VC8000E Encoder library"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
inherit fsl-eula-unpack
@@ -10,8 +10,8 @@ SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
S = "${WORKDIR}/${BPN}-${PV}"
-SRC_URI[md5sum] = "fbd43a100c27abbae301428f1ae2bc64"
-SRC_URI[sha256sum] = "e59ac2ded726d722f61793b17fc394ce87b1c5710cb79f0b1d60b87fca5829e1"
+SRC_URI[md5sum] = "c24e2622c522bb4bc2da710c27389ee4"
+SRC_URI[sha256sum] = "338eaa313cfa6f93eee5930903386fca922f82fda3617ecb2597cc90ccf8f22d"
# SCR is the location and name of the Software Content Register file
# relative to ${D}${D_SUBDIR}.
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.1.bb
index 25f54c7a..d4a48627 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.1.bb
@@ -9,8 +9,8 @@ DEPENDS:append:mx8mp = " imx-vpu-hantro-vc"
SRC_URI = " \
${FSL_MIRROR}/${BP}.tar.gz \
"
-SRC_URI[md5sum] = "980237589af195c2c4b852a7aad175ee"
-SRC_URI[sha256sum] = "a5d915fefd3637e68d693638edd1161c30e75011a6312251b914f04546fd0fc9"
+SRC_URI[md5sum] = "99e96b2e00516d56a78a95a80851076b"
+SRC_URI[sha256sum] = "e7b3d55f72e233179b1b28c03628139b463d1994d140fed3c3e0796c66e917c8"
PLATFORM:mx8mm = "IMX8MM"
PLATFORM:mx8mq = "IMX8MQ"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.24.0.bb
index 427dbf92..84c71610 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.24.0.bb
@@ -2,13 +2,13 @@
DESCRIPTION = "i.MX Hantro VPU library"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
PROVIDES = "virtual/imxvpu"
SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
-SRC_URI[md5sum] = "3f8d4bb593d851d0523d0146131946ae"
-SRC_URI[sha256sum] = "a312a0b6d32ed16527e5bfcff362b231069428362ad5710f816bca019f70c6a2"
+SRC_URI[md5sum] = "1f99c6941b8a51035b52cc5bc72faa3d"
+SRC_URI[sha256sum] = "aa9461a152e13a1caa852f29ae18fd33aebd90c8a2b49519003e632687fe89d6"
inherit fsl-eula-unpack use-imx-headers
diff --git a/recipes-bsp/isp-imx/basler-camera_4.2.2.15.0.bb b/recipes-bsp/isp-imx/basler-camera_4.2.2.16.0.bb
index 0122d273..e7c8a326 100644
--- a/recipes-bsp/isp-imx/basler-camera_4.2.2.15.0.bb
+++ b/recipes-bsp/isp-imx/basler-camera_4.2.2.16.0.bb
@@ -2,14 +2,14 @@
DESCRIPTION = "Basler camera binary drivers"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
inherit fsl-eula-unpack
SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
-SRC_URI[md5sum] = "963339f568e8b0ba5d67328238284d47"
-SRC_URI[sha256sum] = "f4d4aa08103937ddd86b9c0880d07c1e0db1ec7f51a420a8ccc76dcf2fb7dbe6"
+SRC_URI[md5sum] = "489763169857773bade28611e649172e"
+SRC_URI[sha256sum] = "3d4ae594659a697eef7479ca2480cc53f1d460f22bcc1c58104cff63bc6705fe"
do_install() {
dest_dir=${D}/opt/imx8-isp/bin
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.16.0.bb
index 9ede07bd..4411c351 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.16.0.bb
@@ -2,17 +2,16 @@
DESCRIPTION = "i.MX Verisilicon Software ISP"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
DEPENDS = "python3 libdrm virtual/libg2d libtinyxml2-8"
SRC_URI = " \
${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
file://0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch \
- file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \
"
-SRC_URI[md5sum] = "e9e0943b9f4923c767d07901e550c41c"
-SRC_URI[sha256sum] = "13274c0fd442da4b3b9900a7568c59872ffa6408f5699d35eebc6760a8e51297"
+SRC_URI[md5sum] = "f490153dbec234a04416ad41834806b2"
+SRC_URI[sha256sum] = "83b24b9d1f7a40a506a45a1c5c2ef2ca2313fe9b23fde591e3b7dce77ea359ca"
inherit fsl-eula-unpack cmake systemd use-imx-headers
diff --git a/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
index 2abcac9b..f82f7b67 100644
--- a/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
+++ b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a
SRCBRANCH = "lf_v2021.04"
SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "3463140881c523e248d2fcb6bfc9ed25c0db93bd"
+SRCREV = "263b27e076a0f6e5dcc80227a235f0af73718342"
+LOCALVERSION ?= "-imx_v2021.04_5.10.72_2.2.0"
DEPENDS += "flex-native bison-native bc-native dtc-native"
@@ -14,7 +15,4 @@ B = "${WORKDIR}/build"
inherit fsl-u-boot-localversion
-LOCALVERSION ?= "-imx_v2021.04_5.10.35_2.0.0"
-
BOOT_TOOLS = "imx-boot-tools"
-
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
index af502889..5443ceac 100644
--- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
@@ -6,3 +6,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-imx:"
require u-boot-imx_${PV}.bb
require u-boot-mfgtool.inc
+
+UUU_BOOTLOADER_TAGGED = ""
+UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
+UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index bb5809e2..96552eef 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -7,6 +7,15 @@ require u-boot-imx-common_${PV}.inc
PROVIDES += "u-boot"
+inherit uuu_bootloader_tag
+
+UUU_BOOTLOADER = ""
+UUU_BOOTLOADER:mx6 = "${UBOOT_BINARY}"
+UUU_BOOTLOADER:mx7 = "${UBOOT_BINARY}"
+UUU_BOOTLOADER_TAGGED = ""
+UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-tagged.${UBOOT_SUFFIX}"
+UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-tagged.${UBOOT_SUFFIX}"
+
do_deploy:append:mx8m() {
# Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
if [ -n "${UBOOT_CONFIG}" ]