aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb2
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc2
-rw-r--r--recipes-extended/vpp-core/vpp-core.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
index fd9d3a61..f87d8f78 100644
--- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
DEPENDS = "dpdk python-six-native coreutils-native"
RDEPENDS_${PN} = "bash libcrypto libssl python"
-inherit pythonnative
+inherit python3native
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \
"
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 166c874a..f3f1d2c7 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -6,7 +6,7 @@ RDEPENDS_${PN} = "bash libcrypto libssl"
DEPENDS += "python-pycrypto-native"
-inherit pythonnative
+inherit python3native
LDFLAGS += "${TOOLCHAIN_OPTIONS}"
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb
index 53437d1a..9f6d1125 100644
--- a/recipes-extended/vpp-core/vpp-core.bb
+++ b/recipes-extended/vpp-core/vpp-core.bb
@@ -22,7 +22,7 @@ DEPENDS_class-native = "openssl-native python-ply-native util-linux-native"
inherit cmake
inherit pkgconfig
-inherit python-dir pythonnative
+inherit python3-dir python3native
export ARCH="arm64"
export OPENSSL_PATH = "${RECIPE_SYSROOT}"