aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend22
1 files changed, 2 insertions, 20 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index fce3802e..76f1bc28 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,26 +17,8 @@ python () {
# Enable Etnaviv and Freedreno support
PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
-# For NXP BSP, choose between gallium and osmesa, and between enabling
-# dri and swrast or not. gallium and dri are default.
-#
-# For parts with no GPU, use gallium and dri
-PACKAGECONFIG_REMOVE_NXPBSP = ""
-PACKAGECONFIG_APPEND_NXPBSP = ""
-DRIDRIVERS_NXPBSP = ""
-#
-# For parts with GPU but no DRM, use gallium
-PACKAGECONFIG_REMOVE_NXPBSP_imxgpu = "dri"
-DRIDRIVERS_NXPBSP_imxgpu = ""
-#
-# For parts with GPU and DRM, use osmesa, dri, and swrast
-PACKAGECONFIG_REMOVE_NXPBSP_imxgpu_imxdrm = "gallium"
-PACKAGECONFIG_APPEND_NXPBSP_imxgpu_imxdrm = "osmesa"
-DRIDRIVERS_NXPBSP_imxgpu_imxdrm = "swrast"
-#
-PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}"
-PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}"
-DRIDRIVERS_use-nxp-bsp = "${DRIDRIVERS_NXPBSP}"
+# For NXP BSP, GPU drivers don't support dri
+PACKAGECONFIG_remove_imxgpu_use-nxp-bsp = "dri"
BACKEND = \
"${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \