aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 8e590965..22ffb7ff 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -40,7 +40,7 @@ INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \
"
uncomment() {
- if ! (grep "^#$1" $2); then
+ if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then
bbfatal "Commented setting '#$1' not found in file $2"
fi
sed -i -e 's,^#'"$1"','"$1"',g' $2