aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/spice/spice_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/spice/spice_git.bb')
-rw-r--r--recipes-support/spice/spice_git.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index 900259aa..24870a15 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -29,7 +29,10 @@ SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
"
-SRC_URI += "file://spice-fix-CVE-2013-4282.patch"
+SRC_URI += " \
+ file://spice-fix-CVE-2013-4282.patch \
+ file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
+ "
S = "${WORKDIR}/git"
@@ -37,9 +40,6 @@ inherit autotools gettext pythonnative python-dir pkgconfig
DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0"
-EXTRA_OECONF_append = " -Wnone"
-EXTRA_AUTORECONF_append = " -Wnone"
-
export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
@@ -56,6 +56,10 @@ LICENSE_${PN}-protocol = "BSD"
FILES_${PN}-protocol += "${includedir}/spice-1"
FILES_${PN}-protocol += "${datadir}/pkgconfig"
+do_configure_prepend() {
+ mkdir -p ${S}/spice-common/spice-protocol/m4
+}
+
do_install_append() {
cd ${S}/spice-common/spice-protocol
oe_runmake DESTDIR="${D}" install