aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul')
-rw-r--r--recipes-connectivity/consul/consul_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index b96499c4..f4955e2a 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -28,6 +28,10 @@ COMPATIBLE_HOST_mipsarch = "null"
SYSTEMD_SERVICE_${PN} = "consul.service"
SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+do_compile_prepend () {
+ export GO111MODULE=off
+}
+
do_install_append() {
install -d ${D}/${systemd_unitdir}/system
cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system