aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul/consul-migrate_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul/consul-migrate_git.bb')
-rw-r--r--recipes-connectivity/consul/consul-migrate_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul-migrate_git.bb b/recipes-connectivity/consul/consul-migrate_git.bb
new file mode 100644
index 00000000..4cc53b20
--- /dev/null
+++ b/recipes-connectivity/consul/consul-migrate_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Provides data migration for Consul server nodes"
+HOMEPAGE = "https://github.com/hashicorp/consul-migrate"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378"
+
+DEPENDS += "raft raft-boltdb raft-mdb"
+
+PKG_NAME = "github.com/hashicorp/consul-migrate"
+SRC_URI = "git://${PKG_NAME}.git"
+SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710"
+
+inherit golang
+
+SYSROOT_PREPROCESS_FUNCS += "consul_migrate_sysroot_preprocess"
+
+export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
+
+consul_migrate_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
+ cp -a ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
+ install -d ${SYSROOT_DESTDIR}${prefix}/bin
+ cp -a ${D}${prefix}/bin/* ${SYSROOT_DESTDIR}${prefix}/bin/
+}
+
+CLEANBROKEN = "1"
+INSANE_SKIP_${PN} = "ldflags"