aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/neutron-test-nec-plugin-extensions-location.patch24
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb3
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/neutron-test-nec-plugin-extensions-location.patch b/meta-openstack/recipes-devtools/python/python-neutron/neutron-test-nec-plugin-extensions-location.patch
new file mode 100644
index 00000000..bf54c79f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-neutron/neutron-test-nec-plugin-extensions-location.patch
@@ -0,0 +1,24 @@
+neutron test: nec plugin extensions location
+
+Some of the neutron built-in testcases failed
+because they can not find nec plugin extensions
+based on the given the relative path.
+
+So forcing these failure testcases to look for
+these extensions using absolute path.
+
+Signed-off-by: Vu Tran <vu.tran@windriver.com>
+
+diff --git a/neutron/tests/unit/nec/test_nec_plugin.py b/neutron/tests/unit/nec/test_nec_plugin.py
+index 2f913ca..1c3f0ce 100644
+--- a/neutron/tests/unit/nec/test_nec_plugin.py
++++ b/neutron/tests/unit/nec/test_nec_plugin.py
+@@ -37,7 +37,7 @@ OFC_MANAGER = 'neutron.plugins.nec.nec_plugin.ofc_manager.OFCManager'
+ NOTIFIER = 'neutron.plugins.nec.nec_plugin.NECPluginV2AgentNotifierApi'
+ NEC_PLUGIN_INI = """
+ [DEFAULT]
+-api_extensions_path = neutron/plugins/nec/extensions
++api_extensions_path = %PYTHON_SITEPACKAGES_DIR%/neutron/plugins/nec/extensions
+ [OFC]
+ driver = neutron.tests.unit.nec.stub_ofc_driver.StubOFCDriver
+ enable_packet_filter = False
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 3973b63b..c1c67d57 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
file://metadata_agent.ini \
file://neutron-dhcp-agent-netns-cleanup.cron \
file://uuid_wscheck.patch \
+ file://neutron-test-nec-plugin-extensions-location.patch \
"
SRCREV="a8417d78c2675a2ceb5dbfcee70948a88d69e747"
PV="2013.2.3+git${SRCPV}"
@@ -104,6 +105,8 @@ do_install_append() {
-i ${NEUTRON_CONF_DIR}/metadata_agent.ini
cp run_tests.sh ${NEUTRON_CONF_DIR}
+
+ sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/tests/unit/nec/test_nec_plugin.py
}
pkg_postinst_${SRCNAME}-setup () {