aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb b/meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb
new file mode 100644
index 00000000..5b72be17
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Set of handlers for the Python standard library's logging package"
+HOMEPAGE = "https://pypi.python.org/pypi/logutils"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5b3cbf3c3220969afbf461f4a6ac97c9"
+
+PR = "r0"
+SRCNAME = "logutils"
+
+SRC_URI = "https://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "07b2a31d3d48e4f748363d33c03639cd"
+SRC_URI[sha256sum] = "4042b8e57cbe3b01552b3c84191595ae6c36f1ab5aef7e3a6ce5c2f15c297c9c"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# avoid "error: option --single-version-externally-managed not recognized"
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --prefix=${prefix} \
+ --install-lib=${PYTHON_SITEPACKAGES_DIR} \
+ --install-data=${datadir}"