aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-novnc_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-novnc_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-novnc_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-novnc_git.bb b/meta-openstack/recipes-devtools/python/python3-novnc_git.bb
new file mode 100644
index 00000000..b41b5876
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-novnc_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "This package contains the core python parts of NoVNC"
+HOMEPAGE = "https://github.com/kanaka/noVNC"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99aebbcc36b17df855fad64d4b792bff"
+
+SRCREV = "463c39e4af98ec4106b87bbea17e1605aa4c6180"
+PV = "1.3.0"
+
+SRC_URI = "git://github.com/kanaka/noVNC.git;branch=master;protocol=https \
+ file://python-distutils.patch"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += " python3-websockify"