aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-novnc/python-distutils.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-novnc/python-distutils.patch')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-novnc/python-distutils.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-novnc/python-distutils.patch b/meta-openstack/recipes-devtools/python/python3-novnc/python-distutils.patch
new file mode 100644
index 00000000..85befc9f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-novnc/python-distutils.patch
@@ -0,0 +1,19 @@
+Index: git/setup.py
+===================================================================
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,14 @@
++#!/usr/bin/env python
++
++from distutils.core import setup
++
++setup(name='python3-novnc',
++ version='2012.1~e3',
++ description='NoVNC python libraries',
++ author='Ghe Rivero',
++ author_email='ghe.rivero@stackops.com',
++ url='http://www.stackops.com',
++ packages = ['novnc'],
++ package_dir = {'novnc':'utils'},
++ py_modules=['wsproxy','websocket','web','json2graph','img2js'],
++)