aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
index 14bfc470..bc303334 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
@@ -46,7 +46,7 @@ do_install_append() {
}
pkg_postinst_${SRCNAME} () {
-
+ # python-keystone postinst start
if [ "x$D" != "x" ]; then
exit 1
fi
@@ -54,8 +54,9 @@ pkg_postinst_${SRCNAME} () {
# This is to make sure postgres is configured and running
if ! pidof postmaster > /dev/null; then
sudo -u postgres initdb -D /etc/postgresql/
+ sleep 10
/etc/init.d/postgresql start
- sleep 0.2
+ sleep 5
sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
fi
@@ -63,13 +64,16 @@ pkg_postinst_${SRCNAME} () {
keystone-manage db_sync
keystone-manage pki_setup
- #Create users, services and endpoints
+ # Create users, services and endpoints
/etc/init.d/keystone start
- sleep 0.25
+ sleep 2
+
ADMIN_PASSWORD=${ADMIN_PASSWORD} \
SERVICE_PASSWORD=${SERVICE_PASSWORD} \
SERVICE_TENANT_NAME=${SERVICE_TENANT_NAME} \
bash /etc/keystone/identity.sh
+
+ # end python-keystone postinst
}
PACKAGES += " ${SRCNAME}"