aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-jsonpatch_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-jsonpatch_1.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-jsonpatch_1.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-jsonpatch_1.3.bb b/meta-openstack/recipes-devtools/python/python-jsonpatch_1.3.bb
new file mode 100644
index 00000000..42899264
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-jsonpatch_1.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "An implementation of the JSON Patch format"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+SECTION = "devel/python"
+LICENSE = "BSD+"
+LIC_FILES_CHKSUM = "file://jsonpatch.py;beginline=3;endline=30;md5=5cd7d1fbd6b236ed142e4285624f58fe"
+
+PR = "0"
+SRCNAME = "jsonpatch"
+
+SRC_URI = "http://pypi.python.org/packages/source/j/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "d3485ea3bb242656b4d8f167baccfbf2"
+SRC_URI[sha256sum] = "a937c97325aa81ed6e326bd7c34f87f932b6c08ab89549e83c3d9098637d0390"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-jsonpointer"