aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack-qemu
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack-qemu')
-rw-r--r--meta-openstack-qemu/README48
-rw-r--r--meta-openstack-qemu/conf/layer.conf9
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend11
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend11
4 files changed, 79 insertions, 0 deletions
diff --git a/meta-openstack-qemu/README b/meta-openstack-qemu/README
new file mode 100644
index 00000000..63ef70ad
--- /dev/null
+++ b/meta-openstack-qemu/README
@@ -0,0 +1,48 @@
+meta-openstack-qemu
+===================
+
+This layer provides support configuring and deploying OpenStack images that
+are destined to be run under qemu system emulation.
+
+Dependencies
+------------
+
+This layer depends on:
+
+URI: git://github.com/openembedded/oe-core.git
+branch: master
+revision: HEAD
+prio: default
+
+URI: git://github.com/openembedded/meta-oe.git
+patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
+revision: HEAD
+layers: meta-oe
+ meta-networking
+ meta-ruby
+
+URI: git://git.yoctoproject.org/meta-virtualization
+branch: master
+revision: head
+
+meta-openstack
+branch: master
+revision: head
+
+Maintenance
+-----------
+
+Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
+
+When sending single patches, please using something like:
+'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
+
+Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
+
+License
+-------
+
+All metadata is MIT licensed unless otherwise stated. Source code included
+in tree for individual recipes is under the LICENSE stated in each recipe
+(.bb file) unless otherwise stated.
+
diff --git a/meta-openstack-qemu/conf/layer.conf b/meta-openstack-qemu/conf/layer.conf
new file mode 100644
index 00000000..67611435
--- /dev/null
+++ b/meta-openstack-qemu/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "openstack-qemu-layer"
+BBFILE_PATTERN_openstack-qemu-layer := "^${LAYERDIR}/"
+BBFILE_PRIORITY_openstack-qemu-layer = "6"
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
new file mode 100644
index 00000000..45f4307b
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
@@ -0,0 +1,11 @@
+do_install_append() {
+ if [ ! -f "${WORKDIR}/nova.conf" ]; then
+ return
+ fi
+
+ TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
+ NOVA_CONF_DIR=${D}/${sysconfdir}/nova
+
+ sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
+ -i ${NOVA_CONF_DIR}/nova.conf
+}
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend
new file mode 100644
index 00000000..f45a02bf
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend
@@ -0,0 +1,11 @@
+do_install_append() {
+ if [ ! -f "${WORKDIR}/nova.conf" ]; then
+ return
+ fi
+
+ TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
+ NOVA_CONF_DIR=${D}/${sysconfdir}/nova
+
+ sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
+ -i ${NOVA_CONF_DIR}/nova.conf
+} \ No newline at end of file