aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend')
-rw-r--r--meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend b/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend
new file mode 100644
index 00000000..1c89d517
--- /dev/null
+++ b/meta-openstack-controller-test-config/recipes-devtools/python/python-glance_git.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://glance-test-config.init"
+
+do_install_append() {
+ install -m 0755 ${WORKDIR}/glance-test-config.init ${D}${sysconfdir}/init.d/glance-test-config
+}
+
+PACKAGES += " ${SRCNAME}-test-config"
+FILES_${SRCNAME}-test-config = "${sysconfdir}/init.d/glance-test-config"
+
+RDEPENDS_${SRCNAME}-tests += " ${SRCNAME}-test-config"
+
+INITSCRIPT_PACKAGES += " ${SRCNAME}-test-config"
+INITSCRIPT_NAME_${SRCNAME}-test-config = "glance-test-config"
+INITSCRIPT_PARAMS_${SRCNAME}-test-config = "defaults 95 10"