aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/librdmacm/files/0001-librdmacm-needs-libdl.patch (renamed from recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch)21
-rw-r--r--recipes-extended/librdmacm/librdmacm_1.1.0.bb (renamed from recipes-extended/librdmacm/librdmacm_1.0.17.bb)6
2 files changed, 19 insertions, 8 deletions
diff --git a/recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch b/recipes-extended/librdmacm/files/0001-librdmacm-needs-libdl.patch
index bf15bea1..8e62f4b2 100644
--- a/recipes-extended/librdmacm/files/librdmacm-needs-libdl.patch
+++ b/recipes-extended/librdmacm/files/0001-librdmacm-needs-libdl.patch
@@ -1,15 +1,23 @@
+From d2c39b265f397256482154ad7807260b347176fb Mon Sep 17 00:00:00 2001
+From: Dengke Du <dengke.du@windriver.com>
+Date: Thu, 21 Mar 2019 15:58:32 +0800
+Subject: [PATCH] librdmacm needs libdl
+
Librdmacm links against libibverbs, and the current version of libibverbs
uses dlopen(), so librdmacm must also link against libdl.
Upstream-Status: Pending
Signed-off-by: Donn Seeley <donn.seeley@windriver.com>
+Signed-off-by: Dengke Du <dengke.du@windriver.com>
---
- configure.in | 2 ++
+ configure.ac | 2 ++
1 file changed, 2 insertions(+)
---- a/configure.in
-+++ b/configure.in
+diff --git a/configure.ac b/configure.ac
+index 4a43995..2a7f4b9 100644
+--- a/configure.ac
++++ b/configure.ac
@@ -39,6 +39,8 @@ AC_CHECK_SIZEOF(long)
dnl Checks for libraries
AC_CHECK_LIB(pthread, pthread_mutex_init, [],
@@ -17,5 +25,8 @@ Signed-off-by: Donn Seeley <donn.seeley@windriver.com>
+AC_CHECK_LIB(dl, dlsym, [],
+ AC_MSG_ERROR([dlsym() not found. librdmacm requires libdl.]))
if test "$disable_libcheck" != "yes"; then
- AC_CHECK_LIB(ibverbs, ibv_get_device_list, [],
- AC_MSG_ERROR([ibv_get_device_list() not found. librdmacm requires libibverbs.]))
+ AC_CHECK_LIB(ibverbs, ibv_cmd_open_xrcd, [],
+ AC_MSG_ERROR([ibv_cmd_open_xrcd() not found. librdmacm requires libibverbs 1.1.8 or later.]))
+--
+2.7.4
+
diff --git a/recipes-extended/librdmacm/librdmacm_1.0.17.bb b/recipes-extended/librdmacm/librdmacm_1.1.0.bb
index 0ece6659..30a0c943 100644
--- a/recipes-extended/librdmacm/librdmacm_1.0.17.bb
+++ b/recipes-extended/librdmacm/librdmacm_1.1.0.bb
@@ -16,10 +16,10 @@ DEPENDS = "virtual/libibverbs"
# Repo is at http://git.openfabrics.org/git?p=~shefty/librdmacm.git
SRC_URI = "https://www.openfabrics.org/downloads/rdmacm/${BPN}-${PV}.tar.gz \
- file://librdmacm-needs-libdl.patch"
+ file://0001-librdmacm-needs-libdl.patch"
-SRC_URI[md5sum] = "da6fad887e9c24cb01b74b75f8449cb1"
-SRC_URI[sha256sum] = "9381e1bf2c7079fc257b8eee74e731d3e7eec70e539bb4245084a7b05aeecb2a"
+SRC_URI[md5sum] = "9459e523002978ef6e7b852e01d8b29e"
+SRC_URI[sha256sum] = "8f10848d4810585d6d70b443abc876c1db8df5e9b8b07e095c7e6eaf4ac380c5"
inherit autotools