aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb22
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb25
2 files changed, 25 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb b/meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb
deleted file mode 100644
index b33aed6e..00000000
--- a/meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "Compresses linked and inline JavaScript or CSS into single cached files."
-HOMEPAGE = "http://django-compressor.readthedocs.org/en/latest/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=9f8de96acfc347c41ce7c15f2e918ef6"
-
-SRCNAME = "django_compressor"
-
-SRC_URI = "https://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
-"
-
-SRC_URI[md5sum] = "274dd82a45ddd13e111852dd101a5924"
-SRC_URI[sha256sum] = "0189fd1dbf87d802f4e4e21ebc9220f29bbb7771b252a958ad6119f61453e22e"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
-
-RDEPENDS_${PN} += "python-django-appconf \
- "
-
-CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb b/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
new file mode 100644
index 00000000..4bdb706f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Compresses linked and inline JavaScript or CSS into single cached files."
+HOMEPAGE = "http://django-compressor.readthedocs.org/en/latest/"
+SECTION = "devel/python"
+LICENSE = "MIT & BSD-3-Clause & BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=021598d037fd39ab02e53249e1fe4b6f"
+
+SRCNAME = "django_compressor"
+
+SRC_URI = "https://pypi.io/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "21ecfe4e8615eae64f7068a5599df9af"
+SRC_URI[sha256sum] = "ae0051bc0c7a0660c93434e68d617553fccdd573293dfd15aa33f78d2b4954ef"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += " \
+ python-django-appconf \
+ python-rcssmin \
+ python-rjsmin \
+ "
+
+CLEANBROKEN = "1"